Hot Downloads

Welcome, Guest
Username: Password: Remember me

TOPIC: Problem setting up PIX 506e

Problem setting up PIX 506e 10 years 4 months ago #15667

  • josh0
  • josh0's Avatar
  • Offline
  • New Member
  • Posts: 3
  • Karma: 0
I am a little bit lost in configuring my PIX device and was hoping that maybe you guys could help me. I am unable to browse the internet from my pc when using the PIX as my gateway. I can ping my dns server by ip address but that is all. Would someone mind taking a look at my config and pointing me in the right direction please? I would imagine I have something wrong in my access-list but I am not sure what I need to do. Please help.

Thank you.

[code:1]
PIX Version 6.3(5)
interface ethernet0 auto
interface ethernet1 auto
nameif ethernet0 outside security0
nameif ethernet1 inside security100
enable password xxxxx encrypted
passwd xxxxx encrypted
hostname Corporate
domain-name xxxx.com
clock timezone CST -6
clock summer-time CDT recurring
fixup protocol dns maximum-length 512
fixup protocol ftp 21
fixup protocol h323 h225 1720
fixup protocol h323 ras 1718-1719
fixup protocol http 80
fixup protocol rsh 514
fixup protocol rtsp 554
fixup protocol sip 5060
fixup protocol sip udp 5060
fixup protocol skinny 2000
fixup protocol smtp 25
fixup protocol sqlnet 1521
fixup protocol tftp 69
names
name 192.168.0.0 corp
object-group icmp-type icmp_traffic
icmp-object echo-reply
icmp-object source-quench
icmp-object unreachable
icmp-object time-exceeded
access-list PERMIT_IN permit ip any any
access-list PERMIT_IN permit tcp any any
access-list PERMIT_IN permit udp any any
access-list PERMIT_IN permit icmp any any
access-list PERMIT_OUT permit ip any any
access-list PERMIT_OUT permit tcp any any
access-list PERMIT_OUT permit udp any any
access-list PERMIT_OUT permit icmp any any
pager lines 24
logging on
logging monitor debugging
logging buffered debugging
logging host inside 192.168.0.107
mtu outside 1500
mtu inside 1500
ip address outside xx.xxx.xxx.90 255.255.255.248
ip address inside 192.168.0.215 255.255.255.0
ip audit info action alarm
ip audit attack action alarm
pdm location corp 255.255.255.0 inside
pdm location corp 255.255.255.255 inside
pdm location 192.168.0.107 255.255.255.255 inside
pdm location 0.0.0.0 255.255.255.255 outside
pdm logging informational 100
pdm history enable
arp timeout 14400
global (outside) 1 interface
nat (inside) 1 0.0.0.0 0.0.0.0 0 0
access-group PERMIT_OUT in interface outside
access-group PERMIT_IN in interface inside
route outside 0.0.0.0 0.0.0.0 xx.xxx.xxx.89 1
timeout xlate 0:05:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 rpc 0:10:00 h225 1:00:00
timeout h323 0:05:00 mgcp 0:05:00 sip 0:30:00 sip_media 0:02:00
timeout sip-disconnect 0:02:00 sip-invite 0:03:00
timeout uauth 0:05:00 absolute
aaa-server TACACS+ protocol tacacs+
aaa-server TACACS+ max-failed-attempts 3
aaa-server TACACS+ deadtime 10
aaa-server RADIUS protocol radius
aaa-server RADIUS max-failed-attempts 3
aaa-server RADIUS deadtime 10
aaa-server LOCAL protocol local
aaa authentication enable console LOCAL
aaa authentication http console LOCAL
aaa authentication telnet console LOCAL
aaa authorization command LOCAL
http server enable
http corp 255.255.255.0 inside
no snmp-server location
no snmp-server contact
snmp-server community public
no snmp-server enable traps
floodguard enable
sysopt connection permit-ipsec
crypto ipsec transform-set ESP-3DES-MD5 esp-3des esp-md5-hmac
crypto ipsec transform-set strong esp-3des esp-sha-hmac
telnet corp 255.255.255.0 inside
telnet timeout 5
ssh 192.168.0.107 255.255.255.255 inside
ssh timeout 5
console timeout 0
dhcpd dns 4.2.2.1 4.2.2.2
dhcpd lease 3600
dhcpd ping_timeout 750
username josh password xxxxxxx encrypted privilege 15
username netadmin password xxxxxxx encrypted privilege 15
privilege show level 0 command version
privilege show level 0 command curpriv
privilege show level 3 command pdm
privilege show level 3 command blocks
privilege show level 3 command ssh
privilege configure level 3 command who
privilege show level 3 command isakmp
privilege show level 3 command ipsec
privilege show level 3 command vpdn
privilege show level 3 command local-host
privilege show level 3 command interface
privilege show level 3 command ip
privilege configure level 3 command ping
privilege show level 3 command uauth
privilege configure level 5 mode enable command configure
privilege show level 5 command running-config
privilege show level 5 command privilege
privilege show level 5 command clock
privilege show level 5 command ntp
privilege show level 5 mode configure command logging
privilege show level 5 command fragment
terminal width 80
banner motd Authorized access only. If you do not belong here leave!
: end
[/code:1]
The administrator has disabled public write access.

Re: Problem setting up PIX 506e 10 years 4 months ago #16015

  • ramasamy
  • ramasamy's Avatar
  • Offline
  • Frequent Member
  • Posts: 67
  • Karma: 0
Hi,

I am assumeing your network setup as

system ----Switch----PIX----Router
Internet

You have permited every thing your access list is not blocking the web traffic.

Note: First of all, You can remove your access list as you have permited every thing and as you have permited IP any any, tcp and udp any any will include in IP any any.

1) Try to ping your gateway and Router IP address which is connected to PIX

2) Try to access the website by giving the IP address so that you can check whethere the Problem is whith DNS ( IP address of gmail.com is 216.239.57.83) because you are using the global DNS server.

3) Check the route route outside 0.0.0.0 0.0.0.0 xx.xxx.xxx.89 1

The IP address should be the Router interface IP address which is connected to your PIX.

4) Make sure that you have Public IP address on the PIX outside interface.
The administrator has disabled public write access.
Time to create page: 0.082 seconds

CCENT/CCNA

Cisco Routers

  • SSL WebVPN
  • Securing Routers
  • Policy Based Routing
  • Router on-a-Stick

VPN Security

  • Understand DMVPN
  • GRE/IPSec Configuration
  • Site-to-Site IPSec VPN
  • IPSec Modes

Cisco Help

  • VPN Client Windows 8
  • VPN Client Windows 7
  • CCP Display Problem
  • Cisco Support App.

Windows 2012

  • New Features
  • Licensing
  • Hyper-V / VDI
  • Install Hyper-V

Linux

  • File Permissions
  • Webmin
  • Groups - Users
  • Samba Setup