Hot Downloads

Welcome, Guest
Username: Password: Remember me

TOPIC: Dns problems?? Or firewall problems??

Dns problems?? Or firewall problems?? 10 years 10 months ago #12804

Dear all i've got a Cisco pix-506e and everything is working except the web server which is running win2003 standard.

The web server is hosting a domain and every connection from WAN can be accessed in without any problems. When i was going to visit the website from LAN computers, it returned a bad request HTTP400 to me :(

I asked some friends what should i do to resolve the problems but i have no idea still... Would any brothers give me a hand please ??
Is there any settings on the firewall i overlooked? Or do i have to setup some other things on the dns server? I am really not an expert in networkings... Please help =(

Here are the firewall settings (For ref.)
[code:1]
PIX Version 6.3(5)
interface ethernet0 auto
interface ethernet1 auto
nameif ethernet0 outside security0
nameif ethernet1 inside security100
enable password 4n2OceqawzzFYdvt encrypted
passwd 2KFQnbNIdI.2KYOU encrypted
hostname xxxxxxfw
domain-name xxxxxx.hk
fixup protocol dns maximum-length 512
fixup protocol ftp 21
fixup protocol h323 h225 1720
fixup protocol h323 ras 1718-1719
fixup protocol http 80
fixup protocol rsh 514
fixup protocol rtsp 554
fixup protocol sip 5060
fixup protocol sip udp 5060
fixup protocol skinny 2000
fixup protocol smtp 25
fixup protocol sqlnet 1521
fixup protocol tftp 69
names
name 192.168.11.2 server1x
name 202.64.x.y xxx.com
access-list outside_access_in remark Accept HTTP connections to Server1x
access-list outside_access_in permit tcp any host xxx.com eq www
pager lines 24
mtu outside 1500
mtu inside 1500
ip address outside 202.64.x.y 255.255.255.x
ip address inside 192.168.11.1 255.255.255.0
ip audit info action alarm
ip audit attack action alarm
pdm location server1x 255.255.255.255 inside
pdm location wire-assembly.com 255.255.255.255 outside
pdm logging informational 100
pdm history enable
arp timeout 14400
global (outside) 1 202.64.x.y
nat (inside) 1 0.0.0.0 0.0.0.0 0 0
static (inside,outside) wire-assembly.com server1x netmask 255.255.255.255 0 0
access-group outside_access_in in interface outside
route outside 0.0.0.0 0.0.0.0 202.64.x.y 1
timeout xlate 0:05:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 rpc 0:10:00 h225 1:00:00
timeout h323 0:05:00 mgcp 0:05:00 sip 0:30:00 sip_media 0:02:00
timeout sip-disconnect 0:02:00 sip-invite 0:03:00
timeout uauth 0:05:00 absolute
aaa-server TACACS+ protocol tacacs+
aaa-server TACACS+ max-failed-attempts 3
aaa-server TACACS+ deadtime 10
aaa-server RADIUS protocol radius
aaa-server RADIUS max-failed-attempts 3
aaa-server RADIUS deadtime 10
aaa-server LOCAL protocol local
http server enable
http 192.168.11.0 255.255.255.0 inside
no snmp-server location
no snmp-server contact
snmp-server community public
no snmp-server enable traps
floodguard enable
telnet timeout 5
ssh timeout 5
management-access outside
console timeout 0
dhcpd address 192.168.11.50-192.168.11.100 inside
dhcpd dns 202.14.67.4 202.14.67.14
dhcpd lease 3600
dhcpd ping_timeout 750
dhcpd auto_config outside
dhcpd enable inside
terminal width 80
Cryptochecksum:0165b44cc89aa933e61c4528eb36a791
: end
[OK]
[/code:1]
The administrator has disabled public write access.

Re: Dns problems?? Or firewall problems?? 10 years 10 months ago #13010

  • ramasamy
  • ramasamy's Avatar
  • Offline
  • Frequent Member
  • Posts: 67
  • Karma: 0
Dear all i've got a Cisco pix-506e and everything is working except the web server which is running win2003 standard.

The web server is hosting a domain and every connection from WAN can be accessed in without any problems. When i was going to visit the website from LAN computers, it returned a bad request HTTP400 to me :(

[OK]

I think there is a problem with a DNS. As you are able to access the webserver from WAN so the server is working fine. When you are accessing from LAN It will not pass through PIX. So there is no problem with PIX. So You have to check the DNS.
The administrator has disabled public write access.

Re: Dns problems?? Or firewall problems?? 10 years 10 months ago #13030

  • jhun
  • jhun's Avatar
  • Offline
  • Senior Member
  • Posts: 356
  • Karma: 0
hi,

are you using NAT in your network? if so, then accessing a website thru LAN in a NATed environment woud probably make it difficult and sometimes may return errors.

you could try and making a DNS entry on your dns server to point the url of the site to the internal ip address of the webserver hosting the site rather than it having to route from the external address back to the its internal equivalent which may cause NAT to block it.
The administrator has disabled public write access.
Time to create page: 0.079 seconds

CCENT/CCNA

Cisco Routers

  • SSL WebVPN
  • Securing Routers
  • Policy Based Routing
  • Router on-a-Stick

VPN Security

  • Understand DMVPN
  • GRE/IPSec Configuration
  • Site-to-Site IPSec VPN
  • IPSec Modes

Cisco Help

  • VPN Client Windows 8
  • VPN Client Windows 7
  • CCP Display Problem
  • Cisco Support App.

Windows 2012

  • New Features
  • Licensing
  • Hyper-V / VDI
  • Install Hyper-V

Linux

  • File Permissions
  • Webmin
  • Groups - Users
  • Samba Setup