Hot Downloads

Welcome, Guest
Username: Password: Remember me

TOPIC: IPCop Configuration for DHCP Broadband Connection

IPCop Configuration for DHCP Broadband Connection 10 years 11 months ago #12037

  • Maskkkk
  • Maskkkk's Avatar
  • Offline
  • Frequent Member
  • Posts: 42
  • Karma: 0
Hi,
I'm trying to install ipcop on a computer for its use as a router. I have 3 network cards installed on the box, for now I'm only trying to get the red interface to obtain and ip address from my ISP.

I don't understand why it doesn't work since my linksys router connects to my ISP using DHCP, and it works fine (I'm using it right now). (It connects via cable modem, I use Adelphia).

In setup when configuring the RED interface I select DHCP.
In my old router I don't set the DHCP Host Name, but IPCop requires me to set the DHCP host name.

I've also tried to get the red interface working using the dhcpcd command, but I'm not quite sure how to use it.

I noticed in the IPCop documentation you are supposed to be able to figure out the name of the DHCP Host Name using a your IP address. But the documentation isn't very clear about what part of the output to use for the router.

Bellow is the output of the nslookup I did using the ip address of my old router:

[code:1]

With My IP addr (from the router)

leeand00@2[~]$ nslookup 68.70.117.94
Server: 68.168.160.2
Address: 68.168.160.2#53

Non-authoritative answer:
94.117.70.68.in-addr.arpa name = 68-70-117-94.pittpa.adelphia.net.

Authoritative answers can be found from:
117.70.68.in-addr.arpa nameserver = ns1.adelphia.net.
117.70.68.in-addr.arpa nameserver = ns2.adelphia.net.
117.70.68.in-addr.arpa nameserver = ns3.adelphia.net.
ns1.adelphia.net internet address = 24.50.78.2
ns2.adelphia.net internet address = 68.168.224.177
[/code:1]

I also tried running the same command using an ip address that my ISP (Adelphia) told me was the DHCP server, results bellow:

[code:1]
With the IP Adelphia claimed was the DHCP server

leeand00@2[~]$ nslookup 24.54.123.80

Server: 68.168.160.2
Address: 68.168.160.2#53

Non-authoritative answer:
80.123.54.24.in-addr.arpa name = adcdhcp3.pittpa.adelphia.net.

Authoritative answers can be found from:
123.54.24.in-addr.arpa nameserver = ns3.adelphia.net.
123.54.24.in-addr.arpa nameserver = ns1.adelphia.net.
123.54.24.in-addr.arpa nameserver = ns2.adelphia.net.
ns1.adelphia.net internet address = 24.50.78.2
ns2.adelphia.net internet address = 68.168.224.177
ns3.adelphia.net internet address = 68.168.192.17
[/code:1]

Also I'm correct in assuming that the RED interface should be plugged into the cable modem with a cross-over cable?

Thanks,
maskkkk


- A Man is not an island...that's why we have fourms!
The administrator has disabled public write access.

Re: IPCop Configuration for DHCP Broadband Connection 10 years 11 months ago #12048

  • DaLight
  • DaLight's Avatar
  • Offline
  • Honored Member
  • Posts: 1302
  • Karma: 1
I don't think your problem is the DHCP hostname, as your Linksys router worked well without it. It's more likely to be due to one of the following:

1. You need to use a straight-through cable rather than a cross-over cable.

2. Some ISPs restrict connections by MAC address which means that the MAC address of your Linksys router may be currently registered with your ISP.

If the first option does not work, you may need to call your ISP to register your IPCOP's RED interface MAC address.
The administrator has disabled public write access.

You were right, dahLight! 10 years 11 months ago #12076

  • Maskkkk
  • Maskkkk's Avatar
  • Offline
  • Frequent Member
  • Posts: 42
  • Karma: 0
Much to my DahLight,
I fixed the DHCP Hostname, using your advice about changing the cable to a straithough cable and also by noting that a certain configuration file (/var/ipcop/ethernet/settings) has the wrong value as set by a certain configuration program called setup. Apparently it does not allow you to leave the DHCP Hostname blank when you fill it in the the form field. However...this doesn't mean that down at the ISP they can't leave their DHCP Hostname blank. So you have to edit the file manually (don't ask me how I found it!)

The line of /var/ipcop/ethernet/settings which reads:
(Note the ' ' space)
[code:1]RED_DHCP_HOSTNAME=' '[/code:1]
(after running the configuration program for the red interface, should be changed to:
(note the lack of a space charater '')
[code:1]RED_DHCP_HOSTNAME=''[/code:1]
or consiquently it could also read:
[code:1]RED_DHCP_HOSTNAME=[/code:1]

It worked I tell you! And as proof the packets of this message have traveled through that very router!

Thanks DahLight, you really are the ipCop expert![/code]


- A Man is not an island...that's why we have fourms!
The administrator has disabled public write access.

Re: IPCop Configuration for DHCP Broadband Connection 10 years 11 months ago #12084

  • DaLight
  • DaLight's Avatar
  • Offline
  • Honored Member
  • Posts: 1302
  • Karma: 1
Glad to see you got a result, Maskkkk. I see you're also beginning to play around with the underlying configuration files. You will be able to do much more this way than with just the Web GUI (be careful though!!). Let us know if you need any more help with your config.
The administrator has disabled public write access.
Time to create page: 0.079 seconds

CCENT/CCNA

Cisco Routers

  • SSL WebVPN
  • Securing Routers
  • Policy Based Routing
  • Router on-a-Stick

VPN Security

  • Understand DMVPN
  • GRE/IPSec Configuration
  • Site-to-Site IPSec VPN
  • IPSec Modes

Cisco Help

  • VPN Client Windows 8
  • VPN Client Windows 7
  • CCP Display Problem
  • Cisco Support App.

Windows 2012

  • New Features
  • Licensing
  • Hyper-V / VDI
  • Install Hyper-V

Linux

  • File Permissions
  • Webmin
  • Groups - Users
  • Samba Setup