Hot Downloads

Welcome, Guest
Username: Password: Remember me

TOPIC: Auto Switching

Auto Switching 5 years 2 months ago #37422

  • bkash
  • bkash's Avatar
  • Offline
  • Frequent Member
  • Posts: 32
  • Karma: 0
hi,
i have 2 link connection in cisco swithches(C2960) with in 100Meter in LAN.The cisco switch are working in default vlan-1.
1-Link:- Fiber Connection
2.-Link:- UTP cat6 Connection.
so,i want to know,
1. which link is preferred first ?
2. and did we changes in any configuration cisco switched?
plz clear me....
The administrator has disabled public write access.

Re: Auto Switching 5 years 2 months ago #37424

  • Chris
  • Chris's Avatar
  • Offline
  • Administrator
  • Posts: 1446
  • Thank you received: 13
  • Karma: 8
Bkash,

When you have two links between switches, by default, one of the two will be blocked by the spanning tree protocol.

In your case, if both links are 1000Mbit, they will have the same path cost which means then that the one with the lowest MAC address (if my memory serves me well) will be placed in blocked mode.

Which ever the way, I'd highly suggest you ensure the fiber optic link is enabled and the UTP link is placed in blocked mode. You can easily configure this by lowering the STP cost of the fibre link.

For example, if GigabitEthernet 0/2 is the fiber link, enter the following commands to ensure its made the active link:
interface GigabitEthernet0/2
 switchport mode trunk
 spanning-tree cost 5

This will make the 'path cost' for that link much lower than that of the UTP, and STP will automatically start using this link.

On the other hand, you can also do something a bit smarter and 'combine' the two link into one, making it a nice 2Gigbit link between the two switches.

If one link goes down, e.g the fiber, you won't notice it as there won't be any down-time, and your speed will drop to 1Gigbit.

Here are the associated commands that need to be entered for both switches. Assume Gigabit0/1 & Gigabit0/2 are used on both switches:
!
interface Port-channel1
 switchport
 switchport trunk encapsulation dot1q
 switchport mode trunk
!

!
interface GigabitEthernet0/1
 switchport trunk encapsulation dot1q
 switchport mode trunk
 channel-protocol pagp
 channel-group 1 mode auto
!
interface GigabitEthernet0/2
 switchport trunk encapsulation dot1q
 switchport mode trunk
 channel-protocol pagp
 channel-group 1 mode auto
!

Hope that helps!
Chris Partsenidis.
Founder & Editor-in-Chief
www.Firewall.cx
The administrator has disabled public write access.

Re: Auto Switching 5 years 2 months ago #37437

  • bkash
  • bkash's Avatar
  • Offline
  • Frequent Member
  • Posts: 32
  • Karma: 0
Hi Chris,
tx for prompt responce but my network are not in trunk mode all r access mode,i haven't enable to spanning tree. the both link r goes from gig to ether. so what is the possible for auto switching link.
The administrator has disabled public write access.

Re: Auto Switching 5 years 2 months ago #37439

  • Chris
  • Chris's Avatar
  • Offline
  • Administrator
  • Posts: 1446
  • Thank you received: 13
  • Karma: 8
bkash,

If you haven't got any trunks, its not a problem, you can still use the above Port-Channel configuration, but leave out the 'switchport' commands.

On the other hand, if you have disabled STP, then if you don't create a port channel, that means you'll have loops in your network as each of the two links between your switches will start flooding your network with broadcast loops.

I hope this help you.

Cheers,
Chris Partsenidis.
Founder & Editor-in-Chief
www.Firewall.cx
The administrator has disabled public write access.

Re: Auto Switching 5 years 2 months ago #37448

  • bkash
  • bkash's Avatar
  • Offline
  • Frequent Member
  • Posts: 32
  • Karma: 0
Hi Chris,
Im afraid of yur suggestion plz clear me again.."you'll have loops in your network as each of the two links between your switches will start flooding your network with broadcast loops"
Recentaly i hav problem 1 switch.
The UTP is the primary link in all switches but 1 swithc is hav taken fiber link and secondary is UTP but after shut down the fiber link is goes to UTP.also seen both link in cdp.
i could find why this swithc behavior diffrent others.
The administrator has disabled public write access.

Re: Auto Switching 5 years 2 months ago #37451

  • Nevins
  • Nevins's Avatar
  • Offline
  • Expert Member
  • Posts: 438
  • Thank you received: 9
  • Karma: 4
Useful Threads
================================
www.firewall.cx/forum/2-basic-concepts/3...e-resource-page.html
The administrator has disabled public write access.
Time to create page: 0.082 seconds

CCENT/CCNA

Cisco Routers

  • SSL WebVPN
  • Securing Routers
  • Policy Based Routing
  • Router on-a-Stick

VPN Security

  • Understand DMVPN
  • GRE/IPSec Configuration
  • Site-to-Site IPSec VPN
  • IPSec Modes

Cisco Help

  • VPN Client Windows 8
  • VPN Client Windows 7
  • CCP Display Problem
  • Cisco Support App.

Windows 2012

  • New Features
  • Licensing
  • Hyper-V / VDI
  • Install Hyper-V

Linux

  • File Permissions
  • Webmin
  • Groups - Users
  • Samba Setup