Hot Downloads

Welcome, Guest
Username: Password: Remember me
  • Page:
  • 1
  • 2

TOPIC: cisco router as DHCP server with multiple vlans

cisco router as DHCP server with multiple vlans 6 years 2 months ago #35517

Dear Experts,

I want to ask how to deploy a cisco router ios as a dhcp server for multiple vlans for nearly 1200 users. Do tell me if cisco router ios dhcp server is a good choice or not.

I am having a dlink DES6500 layer3 chassis switch.

On dlink 6500 I have configured 50 vlans and one vlan is connected to the utm box for internet. All vlan are talking to each other.

I have a cisco 2851 router and i have configured it as a host and as a dhcp server in a vlan in the router.

But dhcp server is serving the vlan in which it has been configured like vlan 100, but it is not serving other vlans which are configured in the router.
I have disabled ip routing and mentioned the default gateway in the router

Please tell me how a cisco router ios dhcp server can server multiple vlans

regards
amit
The administrator has disabled public write access.

Re: cisco router as DHCP server with multiple vlans 6 years 2 months ago #35518

  • skepticals
  • skepticals's Avatar
  • Offline
  • Expert Member
  • Posts: 783
  • Karma: 0
Yes, the Cisco router can serve multiple VLANs. Just make a DCHP scope for each VLAN. It might be easier to use a Windows box if you have 50 VLANs though.
The administrator has disabled public write access.

Re: cisco router as DHCP server with multiple vlans 6 years 2 months ago #35519

Hi skepticals,

Thanks for your reply,

I dont want to use windows server as dhcp server as there is always a virus threat to it and windows server are very resource hungry and require good h/w configuration if it has to server 1200-1500 clients. So I want to make router as a dhcp server as cisco 2851 as gigabit ethernet ports so I hope no network bandwidth or congestion problems I ll face.

Dhcp server address is 192.168.100.2/24 that is a cisco 2851 router and I have configured native vlan i.e 100 for this ip range in the router


I have configured one dhcp scope per vlan in the router and mentioned ip helper-adress 192.168.100.2 in the vlans which are configured in the 2851 cisco router.

I have also mentioned dhcp exclude address list per vlan

when I m joining the native vlan membership i.e 192.168.100.x I am able to get ip address via dhcp server but when I switch to other vlan I am not able to get ip address from dhcp server.

I havent enabled any dhcp relay information in the dhcp server (cisco 2800 router) but i have enabled dhcp relay in the dlink 6500 layer 3 chassis switch i.e. 192.168.100.2

Pleasse help me why I am not able to get ip address from cisco ios dhcp server when I am in other vlans rather than 192.168.100.x .

Regards
amit
The administrator has disabled public write access.

Re: cisco router as DHCP server with multiple vlans 6 years 2 months ago #35524

  • Chris
  • Chris's Avatar
  • Offline
  • Administrator
  • Posts: 1446
  • Thank you received: 13
  • Karma: 8
amitaussie,

This brings another topic we can cover. We've covered DHCP on a router, but not for multiple VLANs.


If you use a trunk link from your router to your switch, it would probably make things easier for you.

Here's a configuration for a trunk link on a Cisco router:
!
interface GigabitEthernet0/1
no ip address
duplex auto
speed auto
!
interface GigabitEthernet0/1.1
description Data VLAN
encapsulation dot1Q 1 native
ip address 192.168.1.1 255.255.255.0
ip virtual-reassembly
!
interface GigabitEthernet0/1.2
description Voice VLAN2
encapsulation dot1Q 2
ip address 192.168.2.1 255.255.255.0
ip virtual-reassembly
!
interface GigabitEthernet0/1.3
description VLAN3
encapsulation dot1Q 3
ip address 192.168.10.1 255.255.255.0
ip virtual-reassembly
!



From here, all you need to do is create your DHCP scopes and the router will start serving each vlan:

In this example, we are enabling DHCP only for the first two VLANs:
!
ip dhcp pool DATA VLAN
network 192.168.1.0 255.255.255.0
default-router 192.168.1.1
dns-server 192.168.1.2
!
ip dhcp pool Voice-VLAN2
network 192.168.2.0 255.255.255.0
default-router 192.168.2.1
dns-server 192.168.1.2 192.168.1.1
!


We'll cover this topic extensively in a upcoming article.

Cheers,
Chris Partsenidis.
Founder & Editor-in-Chief
www.Firewall.cx
The administrator has disabled public write access.

Re: cisco router as DHCP server with multiple vlans 6 years 2 months ago #35529

  • skepticals
  • skepticals's Avatar
  • Offline
  • Expert Member
  • Posts: 783
  • Karma: 0
You would need to have an IP helper per subnet on the Cisco switch I believe.
The administrator has disabled public write access.

Re: cisco router as DHCP server with multiple vlans 6 years 2 months ago #35530

  • Chris
  • Chris's Avatar
  • Offline
  • Administrator
  • Posts: 1446
  • Thank you received: 13
  • Karma: 8
skepticals,

Correct - however this is applicable only if we do not use a trunk link between the switch and the router.

In the scenario the switch and router are not connected via trunk link, there will be limitations at to the number of VLANs created: One vlan per router port.

The only way I believe amitaussie will be able to do his job will be via trunk link between the switch and router - this will provide the best possible flexibility and will allow him to create as many vlans required. For this, the IP Helper command will not be required as each vlan connects directly to the router and it will serve each DHCP request from the appropriate DHCP pool.


Hope that helps!
Chris Partsenidis.
Founder & Editor-in-Chief
www.Firewall.cx
The administrator has disabled public write access.
  • Page:
  • 1
  • 2
Time to create page: 0.082 seconds

CCENT/CCNA

Cisco Routers

  • SSL WebVPN
  • Securing Routers
  • Policy Based Routing
  • Router on-a-Stick

VPN Security

  • Understand DMVPN
  • GRE/IPSec Configuration
  • Site-to-Site IPSec VPN
  • IPSec Modes

Cisco Help

  • VPN Client Windows 8
  • VPN Client Windows 7
  • CCP Display Problem
  • Cisco Support App.

Windows 2012

  • New Features
  • Licensing
  • Hyper-V / VDI
  • Install Hyper-V

Linux

  • File Permissions
  • Webmin
  • Groups - Users
  • Samba Setup