Hot Downloads

Welcome, Guest
Username: Password: Remember me
  • Page:
  • 1
  • 2

TOPIC: Comcast to Cisco Help

Comcast to Cisco Help 7 years 2 months ago #31856

  • Kenjo56
  • Kenjo56's Avatar
  • Offline
  • New Member
  • Posts: 5
  • Karma: 0
I reset the Comcast modem. and my Fa0/1 interface which was configured with, ip address dhcp was immediately assigned an ip address from comcast. Great!!! I can ping the comcast gateway from my router, and other devices can ping the routers Fa0/1 interface which recieved it address from comcast dhcp, but I still can't ping past the the Fa0/1 interface from any other device. So I got this far by resesting the modem, but now I'm stuck. Hope I made sense. Any thoughs?
The administrator has disabled public write access.

Re: Comcast to Cisco Help 7 years 2 months ago #31858

  • ZiPPy
  • ZiPPy's Avatar
  • Offline
  • Expert Member
  • Posts: 500
  • Karma: 0
Can you post your configuration of the router, so we can take a look.


Cheers,

ZiPPy
ZiPPy
The administrator has disabled public write access.

Comcast - Cisco Continued 7 years 2 months ago #31862

  • Kenjo56
  • Kenjo56's Avatar
  • Offline
  • New Member
  • Posts: 5
  • Karma: 0
Thanks ZIPPy,
I have a 2621 connected to a MLS lab and a frame-relay lab. Just thought I connect to the real world through my Comcast home cable modem. I tried configuring a default route and gateway, but either I configured wrong or thats not the solution. Appreciate you looking. Just passed the 802 now I started with the CCNP certification.

Kenjo56



!
version 12.2
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname IVR
!
enable secret 5 $1$KEzH$rCG1KwXNKWfa4fzLGk/xq0
!
ip subnet-zero
!
!
!
!
!
!
interface FastEthernet0/0
ip address 10.10.10.254 255.255.255.0
duplex auto
speed auto
!
interface Serial0/0
ip address 10.1.12.2 255.255.255.0
no fair-queue
clockrate 64000
!
interface FastEthernet0/1
ip address dhcp
duplex auto
speed auto
!
interface Serial0/1
no ip address
shutdown
!
router eigrp 25
network 10.1.10.0 0.0.0.255
network 10.1.12.0 0.0.0.255
network 10.10.10.0 0.0.0.255
auto-summary
!
ip classless
ip http server
!
banner motd This is the IVR
!
line con 0
exec-timeout 60 0
password cisco
logging synchronous
login
line aux 0
line vty 0 4
password cisco
login
line vty 5 15
password cisco
login
!
end
The administrator has disabled public write access.

Re: Comcast to Cisco Help 7 years 2 months ago #31864

  • S0lo
  • S0lo's Avatar
  • Offline
  • Moderator
  • Posts: 1577
  • Thank you received: 7
  • Karma: 3
I'm assuming here that the Comcast modem is not doing NAT nor routing and that the IP that Fa0/1 got via DHCP is a public IP. If it's a private IP (like 192.168.x.x or 10.x.x.x), then the following will probably not work.

You first need to setup NAT. Try the following (I'm assuming that your internal hosts are connected to the Fa0/0):

[code:1]interface FastEthernet0/0
ip nat inside
!
interface FastEthernet0/1
ip nat outside
!
ip nat inside source list 1 interface FastEthernet0/1 overload
access-list 1 permit 10.10.10.0 0.0.0.255
[/code:1]

For more info on NAT you could try our guide: www.firewall.cx/tk-cisco-routers-nat-overload.php

Then as you said you need a default route, some thing like this:

[code:1]ip route 0.0.0.0 0.0.0.0 <gateway_IP>[/code:1]

Replace <gateway_IP> with the IP of the gateway. Or if you can't know it, you could use:

[code:1]ip route 0.0.0.0 0.0.0.0 FastEthernet0/1[/code:1]

Hope it helps
Studying CCNP...

Ammar Muqaddas
Forum Moderator
www.firewall.cx
The administrator has disabled public write access.

Continued.. 7 years 2 months ago #31865

  • Kenjo56
  • Kenjo56's Avatar
  • Offline
  • New Member
  • Posts: 5
  • Karma: 0
I appreciate your suggestion, I thought NAT might be a solution. I tried your suggested configuration. I appear to be getting a genuine IP address from Comcast 69.139.12.217. It is in the same range as the address assigned by Comcast when connected with my Wireless Router, 69.136.86.? Anyway I still can't ping past the Fa0/1 interface.

If I can't resolve this issue for now, I got plenty other work, but if you have any thoughts...

Thanks

Kenjo56
The administrator has disabled public write access.

Re: Comcast to Cisco Help 7 years 2 months ago #31869

  • S0lo
  • S0lo's Avatar
  • Offline
  • Moderator
  • Posts: 1577
  • Thank you received: 7
  • Karma: 3
Just to make sure this is not a DNS issue, could you try pinging the DNS server from a PC behind Fa0/0 ?
Studying CCNP...

Ammar Muqaddas
Forum Moderator
www.firewall.cx
The administrator has disabled public write access.
  • Page:
  • 1
  • 2
Time to create page: 0.087 seconds

CCENT/CCNA

Cisco Routers

  • SSL WebVPN
  • Securing Routers
  • Policy Based Routing
  • Router on-a-Stick

VPN Security

  • Understand DMVPN
  • GRE/IPSec Configuration
  • Site-to-Site IPSec VPN
  • IPSec Modes

Cisco Help

  • VPN Client Windows 8
  • VPN Client Windows 7
  • CCP Display Problem
  • Cisco Support App.

Windows 2012

  • New Features
  • Licensing
  • Hyper-V / VDI
  • Install Hyper-V

Linux

  • File Permissions
  • Webmin
  • Groups - Users
  • Samba Setup