Hot Downloads

Welcome, Guest
Username: Password: Remember me

TOPIC: Inter VLAn routing between 4 cisco 3750 switches

Inter VLAn routing between 4 cisco 3750 switches 7 years 10 months ago #28174

  • dell
  • dell's Avatar
  • Offline
  • New Member
  • Posts: 1
  • Karma: 0
Hi i have a query regardin intervlan routing between 4 cisco 3750 switches

The 3 main switches ( A,B,C)are connected in triangle shape. These switches form the bachbone of the network

A new switch is connected between A and B this form a new triangle

Link for the network diagram :-

www.box.net/shared/597r13f4i3


how to enable routin between the switches

can any one give the sample configuration of the routing like static or OSPF in cisco 3750 switches

thanking you in advance
dell
The administrator has disabled public write access.

Intervlan switching on layer 3 switches 7 years 9 months ago #28508

  • valkyrnash
  • valkyrnash's Avatar
  • Offline
  • New Member
  • Posts: 11
  • Karma: 0
First, to enable routing on a layer 3 switch, in PRIV EXEC, run "ip routing", this will turn routing on on the switch, as it is not enabled by default. Then on the interfaces you want to do the routing, enter "no switchport". You will then be able to assign IP addresses, etc for this port. For Cisco's documentation on it, go to: http://www.cisco.com/en/US/tech/tk389/tk815/technologies_configuration_example09186a008019e74e.shtml

For a barebones configuration, see below ( I assumed sw A from the diagram for this config)

Current configuration : 1452 bytes
!
version 12.2
no service password-encryption
!
hostname Switch
!
!
ip routing
!
!
!
!
ip ssh version 1
!
port-channel load-balance src-mac
!
interface FastEthernet0/1
no switchport
ip address 10.1.2.1 255.255.255.0
duplex auto
speed auto
!
interface FastEthernet0/2
no switchport
ip address 10.1.1.2 255.255.255.0
duplex auto
speed auto
!
interface FastEthernet0/3
no switchport
ip address 10.1.5.2 255.255.255.0
duplex auto
speed auto
!
interface FastEthernet0/4
!
interface FastEthernet0/5
!
interface FastEthernet0/6
!
interface FastEthernet0/7
!
interface FastEthernet0/8
!
interface FastEthernet0/9
!
interface FastEthernet0/10
!
interface FastEthernet0/11
!
interface FastEthernet0/12
!
interface FastEthernet0/13
!
interface FastEthernet0/14
!
interface FastEthernet0/15
!
interface FastEthernet0/16
!
interface FastEthernet0/17
!
interface FastEthernet0/18
!
interface FastEthernet0/19
!
interface FastEthernet0/20
!
interface FastEthernet0/21
!
interface FastEthernet0/22
!
interface FastEthernet0/23
!
interface FastEthernet0/24
!
interface GigabitEthernet0/1
!
interface GigabitEthernet0/2
!
interface Vlan1
no ip address
shutdown
!
interface Vlan2
ip address 10.2.0.1 255.255.0.0
!
interface Vlan3
ip address 10.3.0.1 255.255.0.0
!
interface Vlan10
ip address 10.10.0.1 255.255.0.0
!
router ospf 1
log-adjacency-changes
!
ip classless
ip route 0.0.0.0 0.0.0.0 200.0.0.1
!
!
!
!
!
line con 0
line vty 0 4
login
!
!
end[url][/url]
The administrator has disabled public write access.

Re: Inter VLAn routing between 4 cisco 3750 switches 7 years 9 months ago #28509

  • Kajitora
  • Kajitora's Avatar
  • Offline
  • Frequent Member
  • Posts: 40
  • Karma: 0
The above is correct. I would suggest having the VLAN interface do the routing through.

So you would use the "ip routing" command. But also, for each VLAN.
"int vlan 10"
"ip address x.x.x.x x.x.x.x"
"no shut"

The ip address of the vlan should be your default gateway for that VLAN. Once you do the ip routing command all normal routing commands will become avialble so you will be able to put a gateway of last resourt if you have a edge router you need it to rout to.
itgamers.blogspot.com
The administrator has disabled public write access.
Time to create page: 0.084 seconds

CCENT/CCNA

Cisco Routers

  • SSL WebVPN
  • Securing Routers
  • Policy Based Routing
  • Router on-a-Stick

VPN Security

  • Understand DMVPN
  • GRE/IPSec Configuration
  • Site-to-Site IPSec VPN
  • IPSec Modes

Cisco Help

  • VPN Client Windows 8
  • VPN Client Windows 7
  • CCP Display Problem
  • Cisco Support App.

Windows 2012

  • New Features
  • Licensing
  • Hyper-V / VDI
  • Install Hyper-V

Linux

  • File Permissions
  • Webmin
  • Groups - Users
  • Samba Setup