Hot Downloads

Welcome, Guest
Username: Password: Remember me

TOPIC: DNS on router to router setup

DNS on router to router setup 8 years 1 month ago #27931

  • seanjuan
  • seanjuan's Avatar
  • Offline
  • New Member
  • Posts: 14
  • Karma: 0
If router A (cisco) is connected to router B (non cisco)and router B is connect to a dsl modem. What dns info should be added to A. Router B can ping public internet adresses and hostnames but Router A can't.
The administrator has disabled public write access.

Re: DNS on router to router setup 8 years 1 month ago #27952

  • Patiot
  • Patiot's Avatar
  • Offline
  • Frequent Member
  • Posts: 45
  • Karma: 0
could you get the configs of both

Thanks
patiot
The administrator has disabled public write access.

Re: DNS on router to router setup 8 years 1 month ago #27955

  • S0lo
  • S0lo's Avatar
  • Offline
  • Moderator
  • Posts: 1577
  • Thank you received: 7
  • Karma: 3
You can set DNS IPs for Router A to be the same as whats in Router B's config. But that doesn't mean it will solve the problem. If A can't ping internet IPs then it could be a routing problem. Make sure you have a default route in A that point to B.

As Patiot suggested, posting the config (even partial) will clear out doubts.
Studying CCNP...

Ammar Muqaddas
Forum Moderator
www.firewall.cx
The administrator has disabled public write access.

Re: DNS on router to router setup 8 years 1 month ago #27972

  • seanjuan
  • seanjuan's Avatar
  • Offline
  • New Member
  • Posts: 14
  • Karma: 0
Here is my running config.........

Current configuration : 2089 bytes
!
version 12.3
no service pad
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname Arthur871
!
boot-start-marker
boot-end-marker
!
enable secret 5 $1$pmZb$l8A9W1y7G1ZrqUkDAMMC/0
!
username arthur871 privilege 15 secret 5 $1$DoqN$jAPmka3wL777cBD2ndpHc0
no aaa new-model
ip subnet-zero
ip cef
no ip dhcp conflict logging
ip dhcp excluded-address 10.0.0.0
ip dhcp excluded-address 10.0.0.255
ip dhcp excluded-address 10.10.0.1
!
ip dhcp pool arthur1
import all
network 10.0.0.0 255.255.255.0
default-router 10.0.0.101
dns-server 192.168.0.1
!
!
ip name-server 192.168.0.1
no ftp-server write-enable
!
!
!
!
!
!
!
interface Loopback0
ip address 10.10.0.1 255.255.255.0
!
interface FastEthernet0
no ip address
!
interface FastEthernet1
no ip address
!
interface FastEthernet2
no ip address
!
interface FastEthernet3
no ip address
!
interface FastEthernet4
description WAN port to Dlink DI624
ip address dhcp
ip nat outside
ip virtual-reassembly
duplex auto
speed auto
!
interface Vlan1
ip address 10.0.0.101 255.255.255.0
ip nat inside
ip virtual-reassembly
!
router rip
version 2
network 10.0.0.0
network 192.168.0.0
no auto-summary
!
ip classless
ip route 0.0.0.0 0.0.0.0 FastEthernet4
!
ip http server
ip http authentication local
ip http secure-server
ip http timeout-policy idle 600 life 86400 requests 10000
ip nat pool overload1 192.168.0.16 192.168.0.16 prefix-length 24
ip nat inside source list 1 pool overload1 overload
!
access-list 1 permit 10.0.0.0 0.0.0.255
access-list 1 permit 192.168.0.0 0.0.0.255
!
control-plane
!
banner motd ^C
Welcome to ArthurNet! Authorized Users Only!!! ^C
!
line con 0
exec-timeout 0 0
password zxxxxxx
logging synchronous
login
no modem enable
transport preferred all
transport output all
line aux 0
password zxxxxxx
login
transport preferred all
transport output all
line vty 0 4
privilege level 15
password zxxxxxx
login local
transport preferred all
transport input telnet ssh
transport output all
!
scheduler max-task-time 5000
end
The administrator has disabled public write access.

Re: DNS on router to router setup 8 years 1 month ago #27974

  • S0lo
  • S0lo's Avatar
  • Offline
  • Moderator
  • Posts: 1577
  • Thank you received: 7
  • Karma: 3
I'm assuming here that this config is for router A. Nothing really wrong with it except that it's using NAT although it is not the edge router!!. I wonder why?. If you have NAT on the dsl modem then you might not need NAT on router A. But still it should work with it. So I'm doubting the problem is from the dsl modem not routing the return traffic back. Here are few things that you might want to look into.

1. First make sure Router B has a valid IP address/mask (192.168.0.0/24 subnet) on the interface that is connected to Router A. I assume here that you can ping B from A.

2. Temporarily change the line:

ip address dhcp

to

ip address 192.168.0.16 255.255.255.0

This will clear out dhcp doubts.

3. Configure both Router B and the dsl modem to participate in RIPv2 advertisements. This will let the dsl modem know were to send traffic destined to 192.168.x.x and 10.0.0.x. If you can't do that (for example, because the dsl modem doesn't support RIP). Then you can instead add a static route on the dsl modem that points to the 192.168.0.0/24 and 10.0.0.0/24. Some thing like this:

ip route 192.168.0.0 255.255.255.0 <interface connected to B>
ip route 10.0.0.0 255.255.255.0 <interface connected to B>

Now ping an internet IP (Not a DNS name). If it works. Then use the same DNS server that you are using in Router B for A and try pinging a DNS name.

Hope some thing here helps.
Studying CCNP...

Ammar Muqaddas
Forum Moderator
www.firewall.cx
The administrator has disabled public write access.

Re: DNS on router to router setup 8 years 2 weeks ago #28207

  • seanjuan
  • seanjuan's Avatar
  • Offline
  • New Member
  • Posts: 14
  • Karma: 0
By following your step 1 and Step 2 along with changing the default route from "ip route 0.0.0.0 0.0.0.0 FastEthernet4" to "ip route 0.0.0.0 0.0.0.0 192.168.0.1" (ip of router B) . I was able to ping via ip and dns to the public internet.


Thanks
The administrator has disabled public write access.
Time to create page: 0.087 seconds

CCENT/CCNA

Cisco Routers

  • SSL WebVPN
  • Securing Routers
  • Policy Based Routing
  • Router on-a-Stick

VPN Security

  • Understand DMVPN
  • GRE/IPSec Configuration
  • Site-to-Site IPSec VPN
  • IPSec Modes

Cisco Help

  • VPN Client Windows 8
  • VPN Client Windows 7
  • CCP Display Problem
  • Cisco Support App.

Windows 2012

  • New Features
  • Licensing
  • Hyper-V / VDI
  • Install Hyper-V

Linux

  • File Permissions
  • Webmin
  • Groups - Users
  • Samba Setup