Hot Downloads

Welcome, Guest
Username: Password: Remember me

TOPIC: Need help configuring Cisco 2800

Need help configuring Cisco 2800 8 years 1 month ago #27917

  • mikeg299
  • mikeg299's Avatar
  • Offline
  • New Member
  • Posts: 8
  • Karma: 0
Hi everyone,

I've started training for Cisco routers. However, I've been tasked with configuring a production 2800 w/ a T1 WIC. I already have a standard TXT config template. The router has SDM preloaded and I can connect to it via hyper terminal.

I could use some guidance on how to import a txt config file. Any help would be much appreciated.

-mike
The administrator has disabled public write access.

Re: Need help configuring Cisco 2800 8 years 1 month ago #27921

  • S0lo
  • S0lo's Avatar
  • Offline
  • Moderator
  • Posts: 1577
  • Thank you received: 7
  • Karma: 3
Perhaps the easiest way is to send the text file directly through the Hyper Terminal. First, remove any irrelevant text from the beginning of your text config, For example, the line "Version 12.x" should be removed.

Now set your router into (config) mode, i.e:
[code:1]Router# configure terminal
Router(config)#
[/code:1]
In Hyper Terminal, click on the [Transfer] menu then click [Send Text File...]. Browse and choose the text config file you have and it be sent to the router directly. This will merge your current running config with the text config you sent.

If for any reason this doesn't work there are other ways you can do it via TFTP or Xmodem. If you want I can brief you or give you a link on it.
Studying CCNP...

Ammar Muqaddas
Forum Moderator
www.firewall.cx
The administrator has disabled public write access.

Re: Need help configuring Cisco 2800 8 years 1 month ago #27923

  • mikeg299
  • mikeg299's Avatar
  • Offline
  • New Member
  • Posts: 8
  • Karma: 0
Hi S0lo,

Thanks so much for the response.

Yeah, I didn't take out the first few lines:
show run
Building configuration...

Current configuration : 943 bytes
!
version 12.4
etc...

Things it didn't like when I pasted the conifg file:

Invalid input for : mmi polling-interval 60

Invalid input for : no mmi auto-configure

Invalid input for : no mmi pvc

I'm not to worried about that right now, or should I be?

Anyways, I need to configure the T1 WIC, the serial IP's given are 192.168.129.37 and .38

I see in the standard config TXT template the lines:
!
interface Serial0/0/0.777 point-to-point
ip address 192.168.128.245 255.255.255.252
frame-relay interface-dlci 777
!
ip classless
ip route 0.0.0.0 0.0.0.0 192.168.128.61
!
ip http server
!
!

Keep in mind that we were given a full class C and the lines I pasted are from a template.
Let me know your thoughts. Thanks again.
The administrator has disabled public write access.

Re: Need help configuring Cisco 2800 8 years 1 month ago #27951

  • S0lo
  • S0lo's Avatar
  • Offline
  • Moderator
  • Posts: 1577
  • Thank you received: 7
  • Karma: 3
I'm not sure to what extent the template config matches your physical/actual scenario. So I'm just going to assume that your connected to frame relay (as the template suggests). A typical setup for frame relay in your case would look something like this:
[code:1]interface Serial0/0/0
no ip address
encapsulation frame-relay
bandwidth 256
!
interface Serial0/0/0.102 point-to-point
ip address 192.168.129.37 255.255.255.252
frame-relay interface-dlci 102
![/code:1]
Replace the 102 above with whatever DLCI your PVC has been configured to in the remote frame relay switch. In your template it's 777. Change the bandwidth command above to specify your actual maximum speed (Committed Rate) in kilobits/sec, that you have bought or has been assigned to the link. This will help the routing protocols determine better routes. Offcourse the other side of the PVC (192.168.129.38 ) has to be configured correctly too.

If your link doesn't come up (protocol down). Then try changing the lmi type like this:
[code:1]Router(config)# interface s0/0/0
Router(config-if)# frame-relay lmi ?
ansi
cisco
q933a
Router(config-if)# frame-relay lmi ansi[/code:1]
If ansi doesn't work try q933a. It has to match what has been set in the frame relay switches side. Tell us if you need more help.
Studying CCNP...

Ammar Muqaddas
Forum Moderator
www.firewall.cx
The administrator has disabled public write access.
Time to create page: 0.079 seconds

CCENT/CCNA

Cisco Routers

  • SSL WebVPN
  • Securing Routers
  • Policy Based Routing
  • Router on-a-Stick

VPN Security

  • Understand DMVPN
  • GRE/IPSec Configuration
  • Site-to-Site IPSec VPN
  • IPSec Modes

Cisco Help

  • VPN Client Windows 8
  • VPN Client Windows 7
  • CCP Display Problem
  • Cisco Support App.

Windows 2012

  • New Features
  • Licensing
  • Hyper-V / VDI
  • Install Hyper-V

Linux

  • File Permissions
  • Webmin
  • Groups - Users
  • Samba Setup