Hot Downloads

Welcome, Guest
Username: Password: Remember me

TOPIC: Cisco ASA 5505 Port Forwarding

Cisco ASA 5505 Port Forwarding 8 years 7 months ago #25753

  • eldersoul
  • eldersoul's Avatar
  • Offline
  • New Member
  • Posts: 1
  • Karma: 0
I think I am losing my mind. I have followed every discussion I could find and as best as I can tell, things are set up as they should be. I simply need to forward port 21. My running config is as follows. Please help!

: Saved
:
ASA Version 7.2(3)
!
hostname ciscoasa
domain-name default.domain.invalid
enable password lCrzpddxiv3Ah07a encrypted
names
!
interface Vlan1
nameif inside
security-level 100
ip address 192.168.1.3 255.255.255.0
!
interface Vlan2
nameif outside
security-level 0
ip address ***.***.***.*** 255.255.255.248
!
interface Ethernet0/0
switchport access vlan 2
!
interface Ethernet0/1
!
interface Ethernet0/2
!
interface Ethernet0/3
!
interface Ethernet0/4
!
interface Ethernet0/5
!
interface Ethernet0/6
!
interface Ethernet0/7
!
passwd 2KFQnbNIdI.2KYOU encrypted
ftp mode passive
dns server-group DefaultDNS
domain-name default.domain.invalid
access-list inside_nat0_outbound extended permit ip host 192.168.1.23 ***.***.***.*** 255.255.255.128
access-list outside_1_cryptomap extended permit ip host 192.168.1.23 ***.***.***.*** 255.255.255.128
access-list outside_cryptomap_1 extended permit ip host 192.168.1.23 ***.***.***.*** 255.255.255.128
access-list outside_access_in extended permit tcp any host 192.168.1.122 eq ftp
pager lines 24
logging asdm informational
mtu outside 1500
mtu inside 1500
no failover
monitor-interface outside
monitor-interface inside
icmp unreachable rate-limit 1 burst-size 1
asdm image disk0:/asdm-523.bin
no asdm history enable
arp timeout 14400
global (outside) 1 interface
nat (inside) 0 access-list inside_nat0_outbound
nat (inside) 1 0.0.0.0 0.0.0.0
static (inside,outside) tcp interface ftp 172.16.1.214 ftp netmask 255.255.255.255
access-group outside_access_in in interface outside
route outside 0.0.0.0 0.0.0.0 ***.***.***.*** 1
timeout xlate 3:00:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02
timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00 mgcp-pat 0:05:00
timeout sip 0:30:00 sip_media 0:02:00 sip-invite 0:03:00 sip-disconnect 0:02:00
timeout uauth 0:05:00 absolute
http server enable
http 192.168.1.0 255.255.255.0 inside
no snmp-server location
no snmp-server contact
snmp-server enable traps snmp authentication linkup linkdown coldstart
crypto ipsec transform-set ESP-3DES-MD5 esp-3des esp-md5-hmac
crypto map outside_map 1 match address outside_1_cryptomap
crypto map outside_map 1 set pfs
crypto map outside_map 1 set peer 199.227.180.130
crypto map outside_map 1 set transform-set ESP-3DES-MD5
crypto map inside_map 1 match address outside_cryptomap_1
crypto map inside_map 1 set peer 199.227.180.130
crypto map inside_map 1 set transform-set ESP-3DES-MD5
crypto map inside_map interface outside
crypto isakmp enable outside
crypto isakmp policy 10
authentication pre-share
encryption 3des
hash md5
group 2
lifetime 86400
telnet timeout 5
ssh timeout 5
console timeout 0
dhcpd auto_config outside
!
dhcpd address 192.168.1.4-192.168.1.254 inside
!

!
class-map inspection_default
match default-inspection-traffic
!
!
policy-map type inspect dns preset_dns_map
parameters
message-length maximum 512
policy-map global_policy
class inspection_default
inspect dns preset_dns_map
inspect ftp
inspect h323 h225
inspect h323 ras
inspect rsh
inspect rtsp
inspect esmtp
inspect sqlnet
inspect skinny
inspect sunrpc
inspect xdmcp
inspect sip
inspect netbios
inspect tftp
!
service-policy global_policy global
tunnel-group ***.***.***.*** type ipsec-l2l
tunnel-group ***.***.***.*** ipsec-attributes
pre-shared-key *
prompt hostname context
Cryptochecksum:3e76f42978e261ae63ef5749eacb3a4d
: end
asdm image disk0:/asdm-523.bin
no asdm history enable
The administrator has disabled public write access.

Re: Cisco ASA 5505 Port Forwarding 8 years 7 months ago #25758

  • Elohim
  • Elohim's Avatar
  • Offline
  • Senior Member
  • Posts: 220
  • Karma: 0
What are you trying to do?
I think I am losing my mind. I have followed every discussion I could find and as best as I can tell, things are set up as they should be. I simply need to forward port 21. My running config is as follows. Please help!

: Saved
:
ASA Version 7.2(3)
!
hostname ciscoasa
domain-name default.domain.invalid
enable password lCrzpddxiv3Ah07a encrypted
names
!
interface Vlan1
nameif inside
security-level 100
ip address 192.168.1.3 255.255.255.0
!
interface Vlan2
nameif outside
security-level 0
ip address ***.***.***.*** 255.255.255.248
!
interface Ethernet0/0
switchport access vlan 2
!
interface Ethernet0/1
!
interface Ethernet0/2
!
interface Ethernet0/3
!
interface Ethernet0/4
!
interface Ethernet0/5
!
interface Ethernet0/6
!
interface Ethernet0/7
!
passwd 2KFQnbNIdI.2KYOU encrypted
ftp mode passive
dns server-group DefaultDNS
domain-name default.domain.invalid
access-list inside_nat0_outbound extended permit ip host 192.168.1.23 ***.***.***.*** 255.255.255.128
access-list outside_1_cryptomap extended permit ip host 192.168.1.23 ***.***.***.*** 255.255.255.128
access-list outside_cryptomap_1 extended permit ip host 192.168.1.23 ***.***.***.*** 255.255.255.128
access-list outside_access_in extended permit tcp any host 192.168.1.122 eq ftp
pager lines 24
logging asdm informational
mtu outside 1500
mtu inside 1500
no failover
monitor-interface outside
monitor-interface inside
icmp unreachable rate-limit 1 burst-size 1
asdm image disk0:/asdm-523.bin
no asdm history enable
arp timeout 14400
global (outside) 1 interface
nat (inside) 0 access-list inside_nat0_outbound
nat (inside) 1 0.0.0.0 0.0.0.0
static (inside,outside) tcp interface ftp 172.16.1.214 ftp netmask 255.255.255.255
access-group outside_access_in in interface outside
route outside 0.0.0.0 0.0.0.0 ***.***.***.*** 1
timeout xlate 3:00:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02
timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00 mgcp-pat 0:05:00
timeout sip 0:30:00 sip_media 0:02:00 sip-invite 0:03:00 sip-disconnect 0:02:00
timeout uauth 0:05:00 absolute
http server enable
http 192.168.1.0 255.255.255.0 inside
no snmp-server location
no snmp-server contact
snmp-server enable traps snmp authentication linkup linkdown coldstart
crypto ipsec transform-set ESP-3DES-MD5 esp-3des esp-md5-hmac
crypto map outside_map 1 match address outside_1_cryptomap
crypto map outside_map 1 set pfs
crypto map outside_map 1 set peer 199.227.180.130
crypto map outside_map 1 set transform-set ESP-3DES-MD5
crypto map inside_map 1 match address outside_cryptomap_1
crypto map inside_map 1 set peer 199.227.180.130
crypto map inside_map 1 set transform-set ESP-3DES-MD5
crypto map inside_map interface outside
crypto isakmp enable outside
crypto isakmp policy 10
authentication pre-share
encryption 3des
hash md5
group 2
lifetime 86400
telnet timeout 5
ssh timeout 5
console timeout 0
dhcpd auto_config outside
!
dhcpd address 192.168.1.4-192.168.1.254 inside
!

!
class-map inspection_default
match default-inspection-traffic
!
!
policy-map type inspect dns preset_dns_map
parameters
message-length maximum 512
policy-map global_policy
class inspection_default
inspect dns preset_dns_map
inspect ftp
inspect h323 h225
inspect h323 ras
inspect rsh
inspect rtsp
inspect esmtp
inspect sqlnet
inspect skinny
inspect sunrpc
inspect xdmcp
inspect sip
inspect netbios
inspect tftp
!
service-policy global_policy global
tunnel-group ***.***.***.*** type ipsec-l2l
tunnel-group ***.***.***.*** ipsec-attributes
pre-shared-key *
prompt hostname context
Cryptochecksum:3e76f42978e261ae63ef5749eacb3a4d
: end
asdm image disk0:/asdm-523.bin
no asdm history enable
The administrator has disabled public write access.

Re: Cisco ASA 5505 Port Forwarding 8 years 6 months ago #26050

  • caelwind
  • caelwind's Avatar
  • Offline
  • New Member
  • Posts: 3
  • Karma: 0
You need to add the following line,

access-list outside_access_in extended permit tcp any interface outside eq ftp

Also is 172.16.1.214 you internal FTP server? Shouldnt it be?

static (inside,outside) tcp interface ftp 192.168.1.122 ftp netmask 255.255.255.255
The administrator has disabled public write access.
Time to create page: 0.092 seconds

CCENT/CCNA

Cisco Routers

  • SSL WebVPN
  • Securing Routers
  • Policy Based Routing
  • Router on-a-Stick

VPN Security

  • Understand DMVPN
  • GRE/IPSec Configuration
  • Site-to-Site IPSec VPN
  • IPSec Modes

Cisco Help

  • VPN Client Windows 8
  • VPN Client Windows 7
  • CCP Display Problem
  • Cisco Support App.

Windows 2012

  • New Features
  • Licensing
  • Hyper-V / VDI
  • Install Hyper-V

Linux

  • File Permissions
  • Webmin
  • Groups - Users
  • Samba Setup