Hot Downloads

Welcome, Guest
Username: Password: Remember me
  • Page:
  • 1
  • 2

TOPIC: ASA 5505 Port forwarding setup

ASA 5505 Port forwarding setup 8 years 9 months ago #25166

  • flipzz
  • flipzz's Avatar
  • Offline
  • New Member
  • Posts: 16
  • Karma: 0
I am setting up a basic config for our firewall. I am trying to make it so inside traffic goes outside fin (this works) and outside traffic only comes in on specified ports. (ex. port 25 goes to internal ip of 192.168.2.6). I am stuck. below is my config, any recommendations to this would be great.

: Saved
:
ASA Version 7.2(3)
!
hostname ciscoasa
enable password XXXXXXXXX encrypted
names
!
interface Vlan1
nameif inside
security-level 100
ip address 192.168.10.1 255.255.255.0
!
interface Vlan2
nameif outside
security-level 0
ip address XXX.XXX.184.51 255.255.255.0
!
interface Ethernet0/0
switchport access vlan 2
!
interface Ethernet0/1
!
interface Ethernet0/2
!
interface Ethernet0/3
!
interface Ethernet0/4
!
interface Ethernet0/5
!
interface Ethernet0/6
!
interface Ethernet0/7
!
passwd XXXXXXXXXXXXX encrypted
ftp mode passive
pager lines 24
logging asdm informational
mtu outside 1500
mtu inside 1500
icmp unreachable rate-limit 1 burst-size 1
no asdm history enable
arp timeout 14400
global (outside) 1 interface
nat (inside) 1 0.0.0.0 0.0.0.0
route outside 0.0.0.0 0.0.0.0 XXX.XXX.184.1 1
timeout xlate 3:00:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02
timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00 mgcp-pat 0:05:00
timeout sip 0:30:00 sip_media 0:02:00 sip-invite 0:03:00 sip-disconnect 0:02:00
timeout uauth 0:05:00 absolute
http server enable
http 192.168.10.0 255.255.255.0 inside
no snmp-server location
no snmp-server contact
snmp-server enable traps snmp authentication linkup linkdown coldstart
telnet timeout 5
ssh timeout 5
console timeout 0
dhcpd auto_config outside
!
dhcpd address 192.168.10.2-192.168.10.254 inside
dhcpd enable inside
!

!
class-map inspection_default
match default-inspection-traffic
!
!
policy-map type inspect dns preset_dns_map
parameters
message-length maximum 512
policy-map global_policy
class inspection_default
inspect dns preset_dns_map
inspect ftp
inspect h323 h225
inspect h323 ras
inspect rsh
inspect rtsp
inspect esmtp
inspect sqlnet
inspect skinny
inspect sunrpc
inspect xdmcp
inspect sip
inspect netbios
inspect tftp
!
service-policy global_policy global
prompt hostname context
Cryptochecksum:52dc79d51910b97a2936e881ed75ec8c
: end

ciscoasa#
The administrator has disabled public write access.

Re: ASA 5505 Port forwarding setup 8 years 9 months ago #25170

  • arsrikum
  • arsrikum's Avatar
  • Offline
  • New Member
  • Posts: 3
  • Karma: 0
Hi this is Aravind .

It seems that you do not have any access-lists configured on the outside interface and there are no static translations too . With out any access lists and translations no connections form a lower security level will be allowed to an interface with higher security level . You have configured pat for outbound connections which means that if a connection is initiated from inside the reply packets would be allowed from outside and all other requests initiated from outside will not be allowed .

If you could give me a better Problem Description I can try to help you

Thanks

Aravind
The administrator has disabled public write access.

Re: ASA 5505 Port forwarding setup 8 years 9 months ago #25172

  • flipzz
  • flipzz's Avatar
  • Offline
  • New Member
  • Posts: 16
  • Karma: 0
I took out my access lists and static routes because they were wrong. I was wondering if anyone had maybe a sample of setting a webserver up in the inside or something.

Thanks in advance.
The administrator has disabled public write access.

Re: ASA 5505 Port forwarding setup 8 years 9 months ago #25173

  • Elohim
  • Elohim's Avatar
  • Offline
  • Senior Member
  • Posts: 220
  • Karma: 0
You use static translations to do port forwarding, i.e.

static (inside,outside) tcp interface 80 10.1.1.1 80


This is an overload port forwarding. Anything coming into the outside interface on port 80 foward to 10.1.1.1 on port 80 as well.
The administrator has disabled public write access.

Re: ASA 5505 Port forwarding setup 8 years 9 months ago #25174

  • arsrikum
  • arsrikum's Avatar
  • Offline
  • New Member
  • Posts: 3
  • Karma: 0
As Elhoim suggested you can have the static statement . But you need to have appropriate access list to allow any outside traffic .

And allocate a physical interface for inside vlan .
The administrator has disabled public write access.

Re: ASA 5505 Port forwarding setup 8 years 9 months ago #25257

  • flipzz
  • flipzz's Avatar
  • Offline
  • New Member
  • Posts: 16
  • Karma: 0
can someone point me to a config that has sample access lists and static routes for porting mail or web thru the asa? From the examples I can make mine.

Thanks
The administrator has disabled public write access.
  • Page:
  • 1
  • 2
Time to create page: 0.084 seconds

CCENT/CCNA

Cisco Routers

  • SSL WebVPN
  • Securing Routers
  • Policy Based Routing
  • Router on-a-Stick

VPN Security

  • Understand DMVPN
  • GRE/IPSec Configuration
  • Site-to-Site IPSec VPN
  • IPSec Modes

Cisco Help

  • VPN Client Windows 8
  • VPN Client Windows 7
  • CCP Display Problem
  • Cisco Support App.

Windows 2012

  • New Features
  • Licensing
  • Hyper-V / VDI
  • Install Hyper-V

Linux

  • File Permissions
  • Webmin
  • Groups - Users
  • Samba Setup