Hot Downloads

Welcome, Guest
Username: Password: Remember me
  • Page:
  • 1
  • 2

TOPIC: Cisco ASA 5505 - Problem to access Internet from Inside host

Cisco ASA 5505 - Problem to access Internet from Inside host 8 years 8 months ago #24788

  • danny_lin
  • danny_lin's Avatar
  • Offline
  • New Member
  • Posts: 3
  • Karma: 0
Hi All,

I have a problem to access Internet from inside host, even I have configured all neccessary ACL for the firewall. The internet connection is PPPoe (Wimax), and it can ping outside directly from the firewall, but if I tried to ping the outside url from inside host, it does not reply.

The following is my configuration of the firewall:
ASA Version 7.2(3)

!

hostname ciscoasa
domain-name default.domain.invalid
enable password [removed by smurf] encrypted
names
name 41.198.x.x outside_world description Internet Address
name 41.0.0.0 outside_network
!
interface Vlan1
nameif inside
security-level 100
ip address 192.168.2.1 255.255.255.0
!
interface Vlan2
nameif outside
security-level 0
pppoe client vpdn group Mweb
ip address pppoe setroute
!
interface Ethernet0/0
switchport access vlan 2
!
<--- More --->
interface Ethernet0/1
!
interface Ethernet0/2
!
interface Ethernet0/3
!
interface Ethernet0/4
!
interface Ethernet0/5
!
interface Ethernet0/6
!
interface Ethernet0/7
!
passwd [removed by smurf] encrypted
ftp mode passive
dns domain-lookup inside
dns domain-lookup outside
dns server-group DefaultDNS
name-server 196.47.x.x
name-server 196.47.x.x
domain-name default.domain.invalid
same-security-traffic permit inter-interface
same-security-traffic permit intra-interface
<--- More --->
object-group service AllowServices tcp
port-object eq ftp
port-object eq www
port-object eq https
port-object eq pop3
port-object eq ssh
object-group network ALLSERVERS
network-object host 192.168.2.10
network-object host 192.168.2.12
access-list inside_nat_static extended permit ip 192.168.2.0 255.255.255.0 host outside_world
access-list inside_access_in extended permit ip 192.168.2.0 s55.255.255.0 192.168.2.0 255.255.255.0
access-list inside_access_in extended permit icmp 192.168.2.0 255.255.255.0 host outside_world
access-list inside_access_in extended permit tcp interface outside interface inside
access-list inside_access_in extended permit tcp 192.168.2.0 255.255.255.0 host outside_world
access-list inside_access_in extended permit tcp interface inside interface inside
access-list aclin extended permit tcp interface outside object-group ALLSERVERS object-group AllowServices
access-list aclout extended permit tcp 192.168.2.0 255.255.255.0 object-group AllowServices interface outside
access-list aclout extended permit ip host outside_world any
access-list aclout extended permit udp 192.168.2.0 255.255.255.0 host outside_world
access-list aclout extended permit ip 192.168.2.0 255.255.255.0 host outside_world
access-list aclout extended permit tcp 192.168.2.0 255.255.255.0 any
pager lines 24
logging enable
logging asdm informational
<--- More --->
mtu inside 1500
mtu outside 1500
icmp unreachable rate-limit 1 burst-size 1
asdm image disk0:/asdm-523.bin
no asdm history enable
arp timeout 14400
global (outside) 1 interface
nat (inside) 1 0.0.0.0 0.0.0.0
static (inside,outside) outside_network access-list aclout
access-group inside_access_in in interface inside
access-group aclout out interface inside
access-group aclin in interface outside
route outside 0.0.0.0 0.0.0.0 192.168.x.x 1
timeout xlate 3:00:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02
timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00 mgcp-pat 0:05:00
timeout sip 0:30:00 sip_media 0:02:00 sip-invite 0:03:00 sip-disconnect 0:02:00
timeout uauth 0:05:00 absolute
http server enable
http 192.168.2.0 255.255.255.0 inside
no snmp-server location
no snmp-server contact
snmp-server enable traps snmp authentication linkup linkdown coldstart
telnet timeout 5
<--- More --->
ssh timeout 5
console timeout 0
vpdn group Mweb request dialout pppoe
vpdn group Mweb localname xxx
vpdn group Mweb ppp authentication chap
vpdn username xxx password *********
dhcpd auto_config outside
!
dhcpd address 192.168.2.2-192.168.2.129 inside
dhcpd enable inside
!
!
class-map inspection_default
match default-inspection-traffic
!
!
policy-map type inspect dns preset_dns_map
parameters
message-length maximum 512
policy-map global_policy
class inspection_default
inspect dns preset_dns_map
inspect ftp
<--- More --->
inspect h323 h225
inspect h323 ras
inspect rsh
inspect rtsp
inspect esmtp
inspect sqlnet
inspect skinny
inspect sunrpc
inspect xdmcp
inspect sip
inspect netbios
inspect tftp
inspect icmp
!
service-policy global_policy global
username lind password [removed by smurf] encrypted
prompt hostname context
Cryptochecksum:dc074ba17adb5edf4e91078e9eb8edff
: end

May anyone please check what could be the error with my configuration? I have tried to reconfigure the firewall for so many times since last year December, but without any success. :cry:

Thanks
The administrator has disabled public write access.

Re: Cisco ASA 5505 - Problem to access Internet from Inside host 8 years 8 months ago #24793

  • sp1k3tou
  • sp1k3tou's Avatar
  • Offline
  • Frequent Member
  • Posts: 65
  • Karma: 0
I have only configured the simple things on the ASA before, but I think your default route is what is making your inside host not be able to get out. What is the ip of your default gateway of your pppoe connection? Thats what your going to want to put in where you have 192.168.x.x You could also load ASDM and watch the firewall logs to see what is going on. If your not sure how to connect to ASDM here is your url for it on the inside https://192.168.2.1

route outside 0.0.0.0 0.0.0.0 192.168.x.x 1
The administrator has disabled public write access.

Re: Cisco ASA 5505 - Problem to access Internet from Inside host 8 years 8 months ago #24796

  • Smurf
  • Smurf's Avatar
  • Offline
  • Moderator
  • Posts: 1390
  • Karma: 1
I think you need to remove the

[code:1]route outside 0.0.0.0 0.0.0.0 192.168.x.x 1[/code:1]

The line [code:1]ip address pppoe setroute[/code:1] (setroute at the end)

should be configuring the default route for you.

If you remove it and do a show route to see if there is a default route configured.

I have not really played with the ASA myself but i think this may be it.

Wayne
Wayne Murphy
Firewall.cx Team Member
www.firewall.cx

Now working for a Security Company called Sec-1 Ltd in the UK, for any
Penetration Testing work visit www.sec-1.com or PM me for details.
The administrator has disabled public write access.

Default route 8 years 8 months ago #24817

  • danny_lin
  • danny_lin's Avatar
  • Offline
  • New Member
  • Posts: 3
  • Karma: 0
I have configured without the default route before, and then it does not have a static route to the ISP when I do show route. The only problem is that only the interface outside can talk to dns server, but not the interface inside. The problem is that the interface inside cannot communicate to the interface outside. That's the only problem that I need to solve now, therefore I can access the Internet.
The administrator has disabled public write access.

Re: Cisco ASA 5505 - Problem to access Internet from Inside host 8 years 8 months ago #24822

  • Smurf
  • Smurf's Avatar
  • Offline
  • Moderator
  • Posts: 1390
  • Karma: 1
Hi there,

Can you confirm, are you trying to ping the External interface from the Internal Interface (or viceversa) ?
Wayne Murphy
Firewall.cx Team Member
www.firewall.cx

Now working for a Security Company called Sec-1 Ltd in the UK, for any
Penetration Testing work visit www.sec-1.com or PM me for details.
The administrator has disabled public write access.

Re: Cisco ASA 5505 - Problem to access Internet from Inside host 8 years 8 months ago #24824

  • danny_lin
  • danny_lin's Avatar
  • Offline
  • New Member
  • Posts: 3
  • Karma: 0
I tried to ping the external interface from internal interface. Internal -> External. The packet is always deny by implicit ACL, when I did packet trace from ASDM.
The administrator has disabled public write access.
  • Page:
  • 1
  • 2
Time to create page: 0.094 seconds

CCENT/CCNA

Cisco Routers

  • SSL WebVPN
  • Securing Routers
  • Policy Based Routing
  • Router on-a-Stick

VPN Security

  • Understand DMVPN
  • GRE/IPSec Configuration
  • Site-to-Site IPSec VPN
  • IPSec Modes

Cisco Help

  • VPN Client Windows 8
  • VPN Client Windows 7
  • CCP Display Problem
  • Cisco Support App.

Windows 2012

  • New Features
  • Licensing
  • Hyper-V / VDI
  • Install Hyper-V

Linux

  • File Permissions
  • Webmin
  • Groups - Users
  • Samba Setup