Hot Downloads

Welcome, Guest
Username: Password: Remember me

TOPIC: My Cisco Lab Woes

My Cisco Lab Woes 9 years 7 months ago #19691

  • surfer
  • surfer's Avatar
  • Offline
  • New Member
  • Posts: 8
  • Karma: 0
First of all, just wanted to say hi and well done on creating these forums. I've used them alot but never really posted on them before.

Anyway, some time ago i bought a cisco lab off ebay and only now have i started to put it all together. However, i've run into a few problems and posted a while ago on another forum dedicated to certification to see if anyone could help out. It seems not so i thought i'd post here.

I have linked up 3 2500 series routers with 3 DB60 cables and configured them as such:

[code:1]2501 Router (Hostname: Charlie)
Serial 0 - 192.168.0.246/30 (James)
Serial 1 - 192.168.0.253/30 (Matt)

2503 Router (Hostname: Matt)
Serial 0 - 192.168.0.254/30 (Charlie)
Serial 1 - 192.168.0.249/30 (James)

2504 Router (Hostname: James)
Serial 0 - 192.168.0.250/30 (Matt)
Serial 1 - 192.168.0.245/30 (Charlie)[/code:1]

Appologies for the names...

Anyway, this only 'half' worked and it appears as though only certain links from router to router work. I spent ages testing this and came up with this:

[code:1]Clocking Receiving Works?

James Se 0 Matt Se 0 NO
James Se 0 Matt Se 1 NO
James Se 1 Matt Se 0 NO
James Se 1 Matt Se 1 NO
Matt Se 0 James Se 0 YES
Matt Se 0 James Se 1 NO
Matt Se 1 James Se 0 YES
Matt Se 1 James Se 1 NO

Matt Se 0 Charlie Se 0 NO
Matt Se 0 Charlie Se 1 YES
Matt Se 1 Charlie Se 0 NO
Matt Se 1 Charlie Se 1 YES
Charlie Se 0 Matt Se 0 NO
Charlie Se 0 Matt Se 1 NO
Charlie Se 1 Matt Se 0 NO
Charlie Se 1 Matt Se 1 NO

Charlie Se 0 James Se 0 NO
Charlie Se 0 James Se 1 NO
Charlie Se 1 James Se 0 NO
Charlie Se 1 James Se 1 NO
James Se 0 Charlie Se 0 NO
James Se 0 Charlie Se 1 NO
James Se 1 Charlie Se 0 NO
James Se 1 Charlie Se 1 NO[/code:1]

As you can see, slightly perplexing. I also tried ALL cables in the links that did work just to test that it wasn't them and it wasn't.

The origonal post i made is here so feel free to check it out. (Mods / Admins feel free to remove the link if you don't want a link to that site on your board).

I'm ready to post any outputs anyone wants!

Thanks in advance!
The administrator has disabled public write access.

Re: My Cisco Lab Woes 9 years 7 months ago #19695

  • Dove
  • Dove's Avatar
  • Offline
  • Distinguished Member
  • Posts: 198
  • Thank you received: 1
  • Karma: 2
Hi There,

I gone through your routers config and found that there is no routing statement placed in. Enable the routing protocol on each router. (The routing protorcol would be depends on your requirement)

Dove
The administrator has disabled public write access.

Re: My Cisco Lab Woes 9 years 7 months ago #19696

  • smitherton
  • smitherton's Avatar
  • Offline
  • Frequent Member
  • Posts: 60
  • Karma: 0
are you familiar with the ip route command? or the router rip command?

Also as I was looking at your other posts I noticed that someone mentioned setting the clock rate on your DCE to 64000, I believe that is incorrect; I have always had sucsess with setting it to 56000. This is also what Cisco recomends.
The administrator has disabled public write access.

Re: My Cisco Lab Woes 9 years 7 months ago #19726

  • surfer
  • surfer's Avatar
  • Offline
  • New Member
  • Posts: 8
  • Karma: 0
Hmm well i don't really see how adding a routing protocol will help when even a basic link between the routers doesn't exist, but i've added it and it's still the same. Also added in the suggested clock rates.

The current configs look like this:

Charlie:[code:1]Building configuration...

Current configuration : 566 bytes
!
version 12.3
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname charlie
!
boot-start-marker
boot-end-marker
!
enable password cisco
!
no aaa new-model
ip subnet-zero
!
!
!
!
interface Ethernet0
no ip address
shutdown
!
interface Serial0
ip address 192.168.0.246 255.255.255.252
clock rate 56000
no fair-queue
!
interface Serial1
ip address 192.168.0.253 255.255.255.252
!
router rip
network 192.168.0.0
!
ip http server
ip classless
!
!
!
!
line con 0
line aux 0
line vty 0 4
login
!
end[/code:1]

James: [code:1]Building configuration...

Current configuration:
!
version 12.1
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname james
!
enable password cisco
!
!
!
!
!
ip subnet-zero
!
!
!
!
interface Serial0
ip address 192.168.0.250 255.255.255.252
no fair-queue
clockrate 56000
!
interface Serial1
ip address 192.168.0.245 255.255.255.252
!
interface TokenRing0
no ip address
shutdown
!
interface BRI0
no ip address
shutdown
!
router rip
network 192.168.0.0
!
ip classless
no ip http server
!
!
line con 0
transport input none
line aux 0
line vty 0 4
login
!
end[/code:1]

Matt: [code:1]Building configuration...

Current configuration : 643 bytes
!
version 12.3
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname matt
!
boot-start-marker
boot-end-marker
!
enable password cisco
!
no aaa new-model
ip subnet-zero
!
!
!
!
interface Ethernet0
no ip address
shutdown
!
interface Serial0
ip address 192.168.0.254 255.255.255.252
clock rate 56000
no fair-queue
!
interface Serial1
ip address 192.168.0.249 255.255.255.252
!
interface BRI0
no ip address
encapsulation hdlc
shutdown
!
router rip
network 192.168.0.0
!
ip http server
ip classless
!
!
!
!
line con 0
exec-timeout 0 0
line aux 0
line vty 0 4
login
!
end[/code:1]

As before the only working connection is matt <----> charlie.

Cheers.
The administrator has disabled public write access.

Re: My Cisco Lab Woes 9 years 7 months ago #19727

  • smitherton
  • smitherton's Avatar
  • Offline
  • Frequent Member
  • Posts: 60
  • Karma: 0
Well, RIPv1 does not support subnetted networks. RIPv2 was introduced to include the subnet Mask. so do a:

Charlie
[code:1]
(config) #router rip
(config-router) #version 2
(config-router) #no auto-summary
(config-router) #netowrk 192.168.0.244
(config-router) #netowrk 192.168.0.252
[/code:1]

Matt

[code:1]
(config) #router rip
(config-router) #version 2
(config-router) #no auto-summary
(config-router) #netowrk 192.168.0.248
(config-router) #netowrk 192.168.0.252
[/code:1]

James
[code:1]
(config) #router rip
(config-router) #version 2
(config-router) #no auto-summary
(config-router) #netowrk 192.168.0.244
(config-router) #netowrk 192.168.0.252
[/code:1]

The"no auto-summary" command tells the router to pick up what subnet the address is on. After you issue these command do a
[code:1]
#show ip route
[/code:1]

You needed to advertise the network address of the subnet your address is in. When you advertise the network address of 192.168.0.0 on a network with a 30 bit mask that address only covers a usable range of 192.168.0.1-192.168.0.2.

Let me know if this helps, or maybe you dont even want to use RIPv2 i.d.k.
The administrator has disabled public write access.

Re: My Cisco Lab Woes 9 years 7 months ago #19732

  • S0lo
  • S0lo's Avatar
  • Offline
  • Moderator
  • Posts: 1577
  • Thank you received: 7
  • Karma: 3
Can you post the output of some example pings from router to router.

Since you have a ring here, You only need a routing protocol if you are pinging an interface that is on the third link that is not connected directly to the pinger router.

Otherwise, if you are pinging an interface on a directly connected link, it should work.

Can you also post the "show ip interface brief" output.
Studying CCNP...

Ammar Muqaddas
Forum Moderator
www.firewall.cx
The administrator has disabled public write access.
Time to create page: 0.091 seconds

CCENT/CCNA

Cisco Routers

  • SSL WebVPN
  • Securing Routers
  • Policy Based Routing
  • Router on-a-Stick

VPN Security

  • Understand DMVPN
  • GRE/IPSec Configuration
  • Site-to-Site IPSec VPN
  • IPSec Modes

Cisco Help

  • VPN Client Windows 8
  • VPN Client Windows 7
  • CCP Display Problem
  • Cisco Support App.

Windows 2012

  • New Features
  • Licensing
  • Hyper-V / VDI
  • Install Hyper-V

Linux

  • File Permissions
  • Webmin
  • Groups - Users
  • Samba Setup