Hot Downloads

Welcome, Guest
Username: Password: Remember me

TOPIC: InterVLAN Bridging

InterVLAN Bridging 9 years 11 months ago #18842

  • Smurf
  • Smurf's Avatar
  • Offline
  • Moderator
  • Posts: 1390
  • Karma: 1
Hi everyone,

Hopefully someone can help me out on this one. It has been highlighted through a problem i was having that i have turned on InterVLAN Routing when i setup Layer 3 capabilities on my Cisco 3750G switch. The only thing is (although it no longer matters since this switch isn't doing the router any more) i have no idea how to turn it off.

I was hoping that someone can point this out to me for the future ?

I beleive that it all depends on what mode the port is in. If its a switchport (layer 2) then it will bridge aswell, however if its not a switchport (layer 3) then it will route.

i.e. switchport mode access (Layer 2)
no switchport (Layer 3) - Must do layer 2 stuff also obviously.

How does this work within VLAN's then ? If i setup a VLAN with 2 ports in it;

[code:1]interface g1/0/1
switchport access vlan 4
no shut
interface g1/0/2
switchport access vlan 4
no shut
interface vlan 4
ip address 10.10.10.254 255.255.255.0
no shut[/code:1]

How do you stop this from InterVLAN Bridging ? What am i missing here that so obvious ?

Thanks in advance
Wayne Murphy
Firewall.cx Team Member
www.firewall.cx

Now working for a Security Company called Sec-1 Ltd in the UK, for any
Penetration Testing work visit www.sec-1.com or PM me for details.
The administrator has disabled public write access.

Re: InterVLAN Bridging 9 years 11 months ago #18844

  • jwj
  • jwj's Avatar
  • Offline
  • Senior Member
  • Posts: 350
  • Karma: 0
I'm a bit confused by your post, but I'll try to answer with what I believe you are trying to do. You turned on Inter-VLAN routing, and now you want it to be turned off? You could delete the static routes or dynamic routing process with the no commands. Some switches also let you turn off routing completely with "no ip routing".

The example you have above will always bridge between the switchports. They are on the same VLAN, if you wanted them to not bridge you'll have to create another VLAN and assign one of the switchports to it. Also, Inter-VLAN bridging is bridging between more than one VLAN, that is done through matching bridge groups to VLAN interfaces.
-Jeremy-
The administrator has disabled public write access.

Re: InterVLAN Bridging 9 years 11 months ago #18846

  • Smurf
  • Smurf's Avatar
  • Offline
  • Moderator
  • Posts: 1390
  • Karma: 1
Sorry its not very clear, I was wondering how you turn on the bridging between the VLAN's ?

In my example, i suspected that i had a problem with InterVLAN Bridging because ARP requests where getting transfered between two VLANs (because of a routing issue with a 3rd party server) so i was wondering how you actually configured the InterVALN bridging on the switch.

I have since decided that the problem was with Proxy ARP that was causing my problems. All is sorted i just wondered how you configured the InterVLAN Bridging ?

Can anyone inlighten me ?

Cheers
Wayne Murphy
Firewall.cx Team Member
www.firewall.cx

Now working for a Security Company called Sec-1 Ltd in the UK, for any
Penetration Testing work visit www.sec-1.com or PM me for details.
The administrator has disabled public write access.
Time to create page: 0.082 seconds

CCENT/CCNA

Cisco Routers

  • SSL WebVPN
  • Securing Routers
  • Policy Based Routing
  • Router on-a-Stick

VPN Security

  • Understand DMVPN
  • GRE/IPSec Configuration
  • Site-to-Site IPSec VPN
  • IPSec Modes

Cisco Help

  • VPN Client Windows 8
  • VPN Client Windows 7
  • CCP Display Problem
  • Cisco Support App.

Windows 2012

  • New Features
  • Licensing
  • Hyper-V / VDI
  • Install Hyper-V

Linux

  • File Permissions
  • Webmin
  • Groups - Users
  • Samba Setup