Hot Downloads

Welcome, Guest
Username: Password: Remember me
  • Page:
  • 1
  • 2

TOPIC: Boson and OSPF

Boson and OSPF 9 years 11 months ago #17194

  • S0lo
  • S0lo's Avatar
  • Offline
  • Moderator
  • Posts: 1577
  • Thank you received: 7
  • Karma: 3
I really need help on this, I'm preparing for CCNA and I have a question on configuring OSPF on boson simulator.

I've setup a network and configured it using RIP, RIP v2, EIGRP and on each setup routing works fine. (each in a seperate setup)

When I came to OSPF I configured it as the book says, However. It does not work properly. The routing tables do not always get filled with all configured subnets !! as a result, some parts of the network is unreachable. I'v put the topology and device configs files in a zip file that you can download here:

www.l0phtbox.net/other/y-net.zip

I'm fed up with it :? I'd appreciate it if some one can tell me were I went wrong.
Studying CCNP...

Ammar Muqaddas
Forum Moderator
www.firewall.cx
The administrator has disabled public write access.

Re: Boson and OSPF 9 years 11 months ago #17196

  • Elohim
  • Elohim's Avatar
  • Offline
  • Senior Member
  • Posts: 220
  • Karma: 0
Post the text config of each router and your network diagram
.
I really need help on this, I'm preparing for CCNA and I have a question on configuring OSPF on boson simulator.

I've setup a network and configured it using RIP, RIP v2, EIGRP and on each setup routing works fine. (each in a seperate setup)

When I came to OSPF I configured it as the book says, However. It does not work properly. The routing tables do not always get filled with all configured subnets !! as a result, some parts of the network is unreachable. I'v put the topology and device configs files in a zip file that you can download here:

www.l0phtbox.net/other/y-net.zip

I'm fed up with it :? I'd appreciate it if some one can tell me were I went wrong.
The administrator has disabled public write access.

Re: Boson and OSPF 9 years 11 months ago #17199

  • S0lo
  • S0lo's Avatar
  • Offline
  • Moderator
  • Posts: 1577
  • Thank you received: 7
  • Karma: 3
Post the text config of each router and your network diagram
.

There you are:

1. Topology File (y-net.top):
[code:1]
[General]
NumberOfRouters=6
NumberOfSwitches=3
NumberOfPCs=2
NumberOfConnectors=10
Version=6.0.315
[Router1]
Hostname=Router 1
Devicename=Router 1
Series=2500
Model=2501
Ethernet=1
FastEthernet=0
GigabitEthernet=0
Token=0
Serial=2
Bri=1
xpos= 6930
ypos= 1920
[Router2]
Hostname=Router 2
Devicename=Router 2
Series=2500
Model=2501
Ethernet=1
FastEthernet=0
GigabitEthernet=0
Token=0
Serial=2
Bri=1
xpos= 6840
ypos= 4140
DCE=0/0
[Router3]
Hostname=Router 3
Devicename=Router 3
Series=2500
Model=2501
Ethernet=1
FastEthernet=0
GigabitEthernet=0
Token=0
Serial=2
Bri=1
xpos= 8130
ypos= 5940
DCE=0/0
[Router4]
Hostname=Router 4
Devicename=Router 4
Series=2500
Model=2501
Ethernet=1
FastEthernet=0
GigabitEthernet=0
Token=0
Serial=2
Bri=1
xpos= 9720
ypos= 4050
DCE=0/0
[Router5]
Hostname=Router 5
Devicename=Router 5
Series=2500
Model=2501
Ethernet=1
FastEthernet=0
GigabitEthernet=0
Token=0
Serial=2
Bri=1
xpos= 9585
ypos= 2010
DCE=0/0
[Router6]
Hostname=Router 6
Devicename=Router 6
Series=2500
Model=2501
Ethernet=1
FastEthernet=0
GigabitEthernet=0
Token=0
Serial=2
Bri=1
xpos= 10485
ypos= 7785
[Switch1]
Hostname=Switch 1
Devicename=Switch 1
Series=2900
Model=2950
Ethernet= 0
FastEthernet= 12
GigabitEthernet= 0
Token= 0
Serial= 0
Bri= 0
xpos= 7785
ypos= 7380
[Switch2]
Hostname=Switch 2
Devicename=Switch 2
Series=2900
Model=2950
Ethernet= 0
FastEthernet= 12
GigabitEthernet= 0
Token= 0
Serial= 0
Bri= 0
xpos= 4665
ypos= 2355
[Switch3]
Hostname=Switch 3
Devicename=Switch 3
Series=2900
Model=2950
Ethernet= 0
FastEthernet= 12
GigabitEthernet= 0
Token= 0
Serial= 0
Bri= 0
xpos= 11280
ypos= 2025
[PC1]
Name=PC 1
Devicename=PC 1
xpos= 6435
ypos= 7725
Model=Win 98
[PC2]
Name=PC 2
Devicename=PC 2
xpos= 10410
ypos= 615
Model=Win 98
[Connector1]
dev1name=Router 1
dev2name=Router 2
dev1interface=Serial 0
connectortype=Serial
dev2interface=Serial 0
caption=R1S0-R2S0
[Connector2]
dev1name=Router 2
dev2name=Router 3
dev1interface=Serial 1
connectortype=Serial
dev2interface=Serial 0
caption=R2S1-R3S0
[Connector3]
dev1name=Router 3
dev2name=Router 4
dev1interface=Serial 1
connectortype=Serial
dev2interface=Serial 0
caption=R3S1-R4S0
[Connector4]
dev1name=Router 4
dev2name=Router 5
dev1interface=Serial 1
connectortype=Serial
dev2interface=Serial 0
caption=R4S1-R5S0
[Connector5]
dev1name=Router 3
dev2name=Switch 1
dev1interface=Ethernet 0
connectortype=Ethernet
dev2interface=Fast Ethernet 0/12
caption=R3E0-S1EFast0/12
[Connector6]
dev1name=PC 1
dev2name=Switch 1
dev1interface=Ethernet 0
connectortype=Ethernet
dev2interface=Fast Ethernet 0/1
caption=PC1,E0-S1EFast0/1
[Connector7]
dev1name=Router 5
dev2name=Switch 3
dev1interface=Ethernet 0
connectortype=Ethernet
dev2interface=Fast Ethernet 0/12
caption=R5E0-S3EFast0/12
[Connector8]
dev1name=Router 1
dev2name=Switch 2
dev1interface=Ethernet 0
connectortype=Ethernet
dev2interface=Fast Ethernet 0/12
caption=R1E0-S2EFast0/12
[Connector9]
dev1name=PC 2
dev2name=Switch 3
dev1interface=Ethernet 0
connectortype=Ethernet
dev2interface=Fast Ethernet 0/1
caption=PC2,E0-S3EFast0/1
[Connector10]
dev1name=Router 6
dev2name=Switch 1
dev1interface=Ethernet 0
connectortype=Ethernet
dev2interface=Fast Ethernet 0/11
caption=R6E0-S1EFast0/11


2. Multi Cinfig File (Y_Net_OSPF_Routing.nwc)

Number of Devices =11
Number of Routers =6
Number of Switches=3
Number of PCs=2


3. Router 1 config (Y_Net_OSPF_Routing1.rtr)

!
Version 12.1
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname Router1
!
!
!
ip subnet-zero
!
!
!
!
!
!
!
!
interface Serial0
ip address 192.168.10.73 255.255.255.252
no ip directed-broadcast
!
interface Serial1
no ip address
no ip directed-broadcast
!
interface Ethernet0
ip address 192.168.10.81 255.255.255.248
no ip directed-broadcast
!
interface Bri0
no ip address
no ip directed-broadcast
!
!
router ospf 100
network 192.168.10.80 0.0.0.7 area 0
network 192.168.10.72 0.0.0.3 area 0
!
ip classless
no ip http server
!
!
!
!
line con 0
transport input none
line aux 0
line vty 0 4
!
no scheduler allocate
end


4. Router 2 config (Y_Net_OSPF_Routing2.rtr)

!
Version 12.1
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname Router2
!
!
!
ip subnet-zero
!
!
!
!
!
!
!
!
interface Serial0
ip address 192.168.10.74 255.255.255.252
no ip directed-broadcast
clock rate 64000
!
interface Serial1
ip address 192.168.10.65 255.255.255.252
no ip directed-broadcast
!
interface Ethernet0
no ip address
no ip directed-broadcast
shutdown
!
interface Bri0
no ip address
no ip directed-broadcast
shutdown
!
!
router ospf 100
network 192.168.10.72 0.0.0.3 area 0
network 192.168.10.64 0.0.0.3 area 0
!
ip classless
no ip http server
!
!
!
!
line con 0
transport input none
line aux 0
line vty 0 4
!
no scheduler allocate
end



5. Router 3 config (Y_Net_OSPF_Routing3.rtr)

!
Version 12.1
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname Router3
!
!
!
ip subnet-zero
!
!
!
!
!
!
!
!
interface Serial0
ip address 192.168.10.66 255.255.255.252
no ip directed-broadcast
clock rate 64000
!
interface Serial1
ip address 192.168.10.69 255.255.255.252
no ip directed-broadcast
!
interface Ethernet0
ip address 10.10.10.1 255.255.255.0
no ip directed-broadcast
!
interface Bri0
no ip address
no ip directed-broadcast
shutdown
!
!
router ospf 100
network 10.10.10.0 0.0.0.255 area 0
network 192.168.10.68 0.0.0.3 area 0
network 192.168.10.64 0.0.0.3 area 0
!
ip classless
no ip http server
!
!
!
!
line con 0
transport input none
line aux 0
line vty 0 4
!
no scheduler allocate
end


6. Router 4 Config (Y_Net_OSPF_Routing4.rtr)


!
Version 12.1
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname Router4
!
!
!
ip subnet-zero
!
!
!
!
!
!
!
!
interface Serial0
ip address 192.168.10.70 255.255.255.252
no ip directed-broadcast
clock rate 64000
!
interface Serial1
ip address 192.168.10.77 255.255.255.252
no ip directed-broadcast
!
interface Ethernet0
no ip address
no ip directed-broadcast
shutdown
!
interface Bri0
no ip address
no ip directed-broadcast
shutdown
!
!
router ospf 100
network 192.168.10.68 0.0.0.3 area 0
network 192.168.10.76 0.0.0.3 area 0
!
ip classless
no ip http server
!
!
!
!
line con 0
transport input none
line aux 0
line vty 0 4
!
no scheduler allocate
end



7. Router 5 config (Y_Net_OSPF_Routing5.rtr)


!
Version 12.1
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname Router5
!
!
!
ip subnet-zero
!
!
!
!
!
!
!
!
interface Serial0
ip address 192.168.10.78 255.255.255.252
no ip directed-broadcast
clock rate 64000
!
interface Serial1
no ip address
no ip directed-broadcast
shutdown
!
interface Ethernet0
ip address 192.168.10.89 255.255.255.248
no ip directed-broadcast
!
interface Bri0
no ip address
no ip directed-broadcast
shutdown
!
!
router ospf 100
network 192.168.10.76 0.0.0.3 area 0
network 192.168.10.88 0.0.0.7 area 0
!
ip classless
no ip http server
!
!
!
!
line con 0
transport input none
line aux 0
line vty 0 4
!
no scheduler allocate
end


8. Router 6 config (Y_Net_OSPF_Routing6.rtr)


!
Version 12.1
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname Router6
!
!
!
ip subnet-zero
!
!
!
!
!
!
!
!
interface Serial0
no ip address
no ip directed-broadcast
shutdown
!
interface Serial1
no ip address
no ip directed-broadcast
shutdown
!
interface Ethernet0
ip address 10.10.10.2 255.255.255.0
no ip directed-broadcast
!
interface Bri0
no ip address
no ip directed-broadcast
shutdown
!
!
router ospf 100
network 10.10.10.0 0.0.0.255 area 0
!
ip classless
no ip http server
!
!
!
!
line con 0
transport input none
line aux 0
line vty 0 4
!
no scheduler allocate
end


9. Switch1 config (Y_Net_OSPF_Routing7.rtr)

!
Version 12.1
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname Switch1
!
!
!
ip subnet-zero
spanning-tree extend system-id
!
!
!
!
!
!
!
!
interface FastEthernet0/1
!
interface FastEthernet0/2
!
interface FastEthernet0/3
!
interface FastEthernet0/4
!
interface FastEthernet0/5
!
interface FastEthernet0/6
!
interface FastEthernet0/7
!
interface FastEthernet0/8
!
interface FastEthernet0/9
!
interface FastEthernet0/10
!
interface FastEthernet0/11
!
interface FastEthernet0/12
!
vtp Server
vtp domain bigdomain
!
interface Vlan 1
no ip address
no ip route-cache
!
!
ip classless
no ip http server
!
!
!
!
line con 0
transport input none
line aux 0
line vty 0 15
!
no scheduler allocate
end



10. Switch2 config (Y_Net_OSPF_Routing8.rtr)

!
Version 12.1
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname Switch2
!
!
!
ip subnet-zero
spanning-tree extend system-id
!
!
!
!
!
!
!
!
interface FastEthernet0/1
!
interface FastEthernet0/2
!
interface FastEthernet0/3
!
interface FastEthernet0/4
!
interface FastEthernet0/5
!
interface FastEthernet0/6
!
interface FastEthernet0/7
!
interface FastEthernet0/8
!
interface FastEthernet0/9
!
interface FastEthernet0/10
!
interface FastEthernet0/11
!
interface FastEthernet0/12
!
vtp Server
vtp domain bigdomain
!
interface Vlan 1
no ip address
no ip route-cache
!
!
ip classless
no ip http server
!
!
!
!
line con 0
transport input none
line aux 0
line vty 0 15
!
no scheduler allocate
end


11. Switch3 config (Y_Net_OSPF_Routing9.rtr)

!
Version 12.1
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname Switch3
!
!
!
ip subnet-zero
spanning-tree extend system-id
!
!
!
!
!
!
!
!
interface FastEthernet0/1
!
interface FastEthernet0/2
!
interface FastEthernet0/3
!
interface FastEthernet0/4
!
interface FastEthernet0/5
!
interface FastEthernet0/6
!
interface FastEthernet0/7
!
interface FastEthernet0/8
!
interface FastEthernet0/9
!
interface FastEthernet0/10
!
interface FastEthernet0/11
!
interface FastEthernet0/12
!
vtp Server
vtp domain bigdomain
!
interface Vlan 1
no ip address
no ip route-cache
!
!
ip classless
no ip http server
!
!
!
!
line con 0
transport input none
line aux 0
line vty 0 15
!
no scheduler allocate
end
[/code:1]

And finaly here is the topology as an image: www.l0phtbox.net/other/y-topology.gif
Studying CCNP...

Ammar Muqaddas
Forum Moderator
www.firewall.cx
The administrator has disabled public write access.

Re: Boson and OSPF 9 years 11 months ago #17206

  • Elohim
  • Elohim's Avatar
  • Offline
  • Senior Member
  • Posts: 220
  • Karma: 0
I believe your serial interfaces needs some from of encapsulation to start off with and then depending on type of network your serial interfaces are, you need to specify the type of OSPF network.

At the command prompt, post the out of

show ip ospf neighbor

from each of the routers.

I really need help on this, I'm preparing for CCNA and I have a question on configuring OSPF on boson simulator.

I've setup a network and configured it using RIP, RIP v2, EIGRP and on each setup routing works fine. (each in a seperate setup)

When I came to OSPF I configured it as the book says, However. It does not work properly. The routing tables do not always get filled with all configured subnets !! as a result, some parts of the network is unreachable. I'v put the topology and device configs files in a zip file that you can download here:

www.l0phtbox.net/other/y-net.zip

I'm fed up with it :? I'd appreciate it if some one can tell me were I went wrong.
The administrator has disabled public write access.

Re: Boson and OSPF 9 years 11 months ago #17207

  • S0lo
  • S0lo's Avatar
  • Offline
  • Moderator
  • Posts: 1577
  • Thank you received: 7
  • Karma: 3
Here are they:

Router1#sh ip ospf neig
Neighbor ID Pri State Dead Time Address Interface
192.168.10.74 0 FULL/ 00:00:53 192.168.10.74 Serial0


Router2#sh ip ospf neig
Neighbor ID Pri State Dead Time Address Interface
192.168.10.69 0 FULL/ 00:04:54 192.168.10.66 Serial1
192.168.10.81 0 FULL/ 00:04:54 192.168.10.73 Serial0


Router3#sh ip ospf neig
Neighbor ID Pri State Dead Time Address Interface
192.168.10.77 0 FULL/ 00:06:41 192.168.10.70 Serial1
192.168.10.74 0 FULL/ 00:06:41 192.168.10.65 Serial0
10.10.10.2 0 FULL/ 00:06:41 10.10.10.2 Ethernet0


Router4#sh ip ospf neig
Neighbor ID Pri State Dead Time Address Interface
192.168.10.89 0 FULL/ 00:06:21 192.168.10.78 Serial1
192.168.10.69 0 FULL/ 00:06:21 192.168.10.69 Serial0


Router5#sh ip ospf neig
Neighbor ID Pri State Dead Time Address Interface
192.168.10.77 0 FULL/ 00:07:52 192.168.10.77 Serial0


Router6#sh ip ospf neig
Neighbor ID Pri State Dead Time Address Interface
192.168.10.69 0 FULL/ 00:07:11 10.10.10.1 Ethernet0
Studying CCNP...

Ammar Muqaddas
Forum Moderator
www.firewall.cx
The administrator has disabled public write access.

Re: Boson and OSPF 9 years 11 months ago #17209

  • S0lo
  • S0lo's Avatar
  • Offline
  • Moderator
  • Posts: 1577
  • Thank you received: 7
  • Karma: 3
I have 7 subnets in the network, shouldn't thier be 7 routes in each routers routing table. I'm getting only 5 subnets in Router 1

Router1#sh ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, * - candidate default
U - per-user static route

Gateway of last resort is not set

192.168.10.0/24 is variably subnetted, 4 subnets
C 192.168.10.72/30 is directly connected, Serial0
C 192.168.10.80/29 is directly connected, Ethernet0
O 192.168.10.64/30 [110/128] via 192.168.10.74, 00:23:24, Serial0
O 192.168.10.68/30 [110/256] via 192.168.10.74, 00:23:19, Serial0
10.0.0.0/24 is subnetted, 1 subnets
O 10.10.10.0 [110/202] via 192.168.10.74, 00:23:19, Serial0


Also for example in router4, I'm getting 6

Router4#sh ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, * - candidate default
U - per-user static route

Gateway of last resort is not set

192.168.10.0/24 is variably subnetted, 5 subnets
C 192.168.10.68/30 is directly connected, Serial0
O 192.168.10.88/29 [110/64] via 192.168.10.78, 00:30:07, Serial1
O 192.168.10.64/30 [110/64] via 192.168.10.69, 00:30:07, Serial0
C 192.168.10.76/30 is directly connected, Serial1
O 192.168.10.72/30 [110/384] via 192.168.10.69, 00:30:02, Serial0
10.0.0.0/24 is subnetted, 1 subnets
O 10.10.10.0 [110/64] via 10.10.10.1, 00:30:07, Serial0


The same for all other routers, I never get 7 routes. For EIGRP, RIPv2 all 7 were there!!
Studying CCNP...

Ammar Muqaddas
Forum Moderator
www.firewall.cx
The administrator has disabled public write access.
  • Page:
  • 1
  • 2
Time to create page: 0.211 seconds

CCENT/CCNA

Cisco Routers

  • SSL WebVPN
  • Securing Routers
  • Policy Based Routing
  • Router on-a-Stick

VPN Security

  • Understand DMVPN
  • GRE/IPSec Configuration
  • Site-to-Site IPSec VPN
  • IPSec Modes

Cisco Help

  • VPN Client Windows 8
  • VPN Client Windows 7
  • CCP Display Problem
  • Cisco Support App.

Windows 2012

  • New Features
  • Licensing
  • Hyper-V / VDI
  • Install Hyper-V

Linux

  • File Permissions
  • Webmin
  • Groups - Users
  • Samba Setup