Hot Downloads

Welcome, Guest
Username: Password: Remember me

TOPIC: Configuring NAT with Frame Relay

Configuring NAT with Frame Relay 10 years 3 months ago #16187

  • Dove
  • Dove's Avatar
  • Offline
  • Distinguished Member
  • Posts: 198
  • Thank you received: 1
  • Karma: 2
Hi,
I am preparing for my CCNA. I am using the Boson Netsim. In my network there are four router connected into the Frame relay cloud. EIGRP routing is running on each router. Each routers are able to ping with each other.

After that I gave the follwoing command for NATing on Router1


ip nat pool p1 192.168.0.1 192.168.0.255
ip nat inside source list 1 pool p1

access-list 1 permit 192.168.0.0 0.0.0.255

r1(Config)int f0/0
r1(Config-if)ip nat inside
r1(Config)int s0/0
r1(Config-if)ip nat outside

when I checked after configuring this I found that the NAT was not working.

even the sh ip nat trans also blank.


Please some one help how to configure the NAT on Frame Relay network.

Note : The same Nat Configuration is working well if the router are connected through the Serial ports (Directly connected).


Thanks in advance

Regards,
Dove

Dove
The administrator has disabled public write access.

Re: Configuring NAT with Frame Relay 10 years 3 months ago #16394

  • Dove
  • Dove's Avatar
  • Offline
  • Distinguished Member
  • Posts: 198
  • Thank you received: 1
  • Karma: 2
can anyone guide me on this problem...

Dove

Dove
The administrator has disabled public write access.

Re: Configuring NAT with Frame Relay 10 years 3 months ago #16397

  • d_jabsd
  • d_jabsd's Avatar
  • Offline
  • Distinguished Member
  • Posts: 153
  • Karma: 0
By default, Cisco's IP NAT assumes a 1 to 1 nat with each address, requiring a public subnet equal to or larger than the private subnet.

You need to enable PAT (Port address translation) in order to nat a private subnet to a single public address.

add 'overload' to the ip nat source line to enable PAT, and everything should work.
Also, it looks like your source line is directing the nat back to the inside.

Try this:
ip nat outside source list 1 pool p1 overload

Let us know how everything works out.
The administrator has disabled public write access.

Re: Configuring NAT with Frame Relay 10 years 3 months ago #16400

  • d_jabsd
  • d_jabsd's Avatar
  • Offline
  • Distinguished Member
  • Posts: 153
  • Karma: 0
Try this:
ip nat outside source list 1 pool p1 overload

Did some more research and your source list should be ip nat inside like you specified before.

sorry about that..

but give overload a try. should make everything work.
The administrator has disabled public write access.

Re: Configuring NAT with Frame Relay 10 years 3 months ago #16435

  • Dove
  • Dove's Avatar
  • Offline
  • Distinguished Member
  • Posts: 198
  • Thank you received: 1
  • Karma: 2
Thanks for your reply.

My query is, I configured the router with the Sub-interfaces I hope because of that only my NAT configuration was not working....I dont find NAT command for each sub interfaces....

Please tell me how to configure the NAT for each sub-interfaces. Also let me know is I hv to configure the NAT globaly to all subinterface are by seperate...



Thanks
Dove

Dove
The administrator has disabled public write access.
Time to create page: 0.082 seconds

CCENT/CCNA

Cisco Routers

  • SSL WebVPN
  • Securing Routers
  • Policy Based Routing
  • Router on-a-Stick

VPN Security

  • Understand DMVPN
  • GRE/IPSec Configuration
  • Site-to-Site IPSec VPN
  • IPSec Modes

Cisco Help

  • VPN Client Windows 8
  • VPN Client Windows 7
  • CCP Display Problem
  • Cisco Support App.

Windows 2012

  • New Features
  • Licensing
  • Hyper-V / VDI
  • Install Hyper-V

Linux

  • File Permissions
  • Webmin
  • Groups - Users
  • Samba Setup