Hot Downloads

Welcome, Guest
Username: Password: Remember me

TOPIC: 2924/2924C Vlan keeps dropping off?

2924/2924C Vlan keeps dropping off? 10 years 8 months ago #12857

  • illness
  • illness's Avatar
  • Offline
  • Frequent Member
  • Posts: 28
  • Karma: 0
I have a building full of cisco 2924/2924C's...

I have a few problems that i can't seem to find an answer for on the good old internet.

1. My management Vlan1 on individual switches sometimes drops off the network and i can't telnet or ping to it. The switch is working fine because it's in production and i can ping addresses on other switchs. I can even console into the switch and everything looks fine...

I can restart the switch and the problem goes away... ?

Is this the best workaround? Is there a way to restart or refresh this connection without bouncing the power on the switch?

Case in point, here is the info on one of the switch's VLAN that is currently down:
[code:1]
sh ver
Cisco Internetwork Operating System Software
IOS (tm) C2900XL Software (C2900XL-C3H2S-M), Version 12.0(5.2)XU, MAINTENANCE INTERIM SOFTWARE
Copyright (c) 1986-2000 by cisco Systems, Inc.
Compiled Mon 17-Jul-00 17:35 by ayounes
Image text-base: 0x00003000, data-base: 0x00301F3C

ROM: Bootstrap program is C2900XL boot loader

swprcore03 uptime is 3 weeks, 1 day, 19 hours, 54 minutes
System returned to ROM by power-on
System image file is "flash:c2900XL-c3h2s-mz-120.5.2-XU.bin"


cisco WS-C2924C-XL (PowerPC403GA) processor (revision 0x11) with 8192K/1024K bytes of memory.
Processor board ID FAB0438S3FF, with hardware revision 0x01
Last reset from power-on

Processor is running Enterprise Edition Software
Cluster command switch capable
Cluster member switch capable
24 FastEthernet/IEEE 802.3 interface(s)
32K bytes of flash-simulated non-volatile configuration memory.
Base ethernet MAC Address: 00:03:6B:4C:31:80
Motherboard assembly number: 73-3381-08
Power supply part number: 34-0834-01
Motherboard serial number: FAB0434117A
Power supply serial number: PHI041305NA
Model revision number: A0
Motherboard revision number: B0
Model number: WS-C2924C-XL-EN
System serial number: FAB0438S3FF
Configuration register is 0xF
[/code:1]


The VLAN1 info
[code:1]
swprcore03#sh int VLAN 1
VLAN1 is up, line protocol is up
Hardware is CPU Interface, address is 0003.6b4c.3180 (bia 0003.6b4c.3180)
Internet address is 192.168.3.23/22
MTU 1500 bytes, BW 10000 Kbit, DLY 1000 usec,
reliability 255/255, txload 1/255, rxload 1/255
Encapsulation ARPA, loopback not set
ARP type: ARPA, ARP Timeout 04:00:00
Last input 00:00:00, output 00:38:17, output hang never
Last clearing of "show interface" counters never
Queueing strategy: fifo
Output queue 0/40, 0 drops; input queue 0/75, 0 drops
5 minute input rate 0 bits/sec, 1 packets/sec
5 minute output rate 0 bits/sec, 0 packets/sec
2390511 packets input, 221017141 bytes, 0 no buffer
Received 2390216 broadcasts, 0 runts, 0 giants, 0 throttles
0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored
0 input packets with dribble condition detected
1545 packets output, 203585 bytes, 0 underruns
0 output errors, 0 collisions, 1 interface resets
0 babbles, 0 late collision, 0 deferred
0 lost carrier, 0 no carrier
0 output buffer failures, 0 output buffers swapped out
[/code:1]


The config:

[code:1]
show config
Using 1270 out of 32768 bytes
!
version 12.0
no service pad
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname swprcore03
!
enable secret 5 (I cleared the data here)
!
!
!
!
!
clock timezone eastern -5
!
ip subnet-zero
!
!
!
interface FastEthernet0/1
spanning-tree portfast
!
interface FastEthernet0/2
!
interface FastEthernet0/3
!
interface FastEthernet0/4
!
interface FastEthernet0/5
!
interface FastEthernet0/6
!
interface FastEthernet0/7
!
interface FastEthernet0/8
!
interface FastEthernet0/9
!
interface FastEthernet0/10
!
interface FastEthernet0/11
!
interface FastEthernet0/12
!
!interface FastEthernet0/13
!
interface FastEthernet0/14
!
interface FastEthernet0/15
!
interface FastEthernet0/16
!
interface FastEthernet0/17
!
interface FastEthernet0/18
!
interface FastEthernet0/19
!
interface FastEthernet0/20
!
interface FastEthernet0/21
!
interface FastEthernet0/22
!
interface FastEthernet0/23
!
interface FastEthernet0/24
!
interface VLAN1
ip address 192.168.3.23 255.255.252.0
ip directed-broadcast
no ip route-cache
!
ip default-gateway 192.168.3.11
logging trap debugging
logging 192.168.3.66
!
line con 0
transport input none
stopbits 1
line vty 0 4
password (I cleared this)
login
line vty 5 15
password (I cleared this)
login
!
end
[/code:1]

2.I have other switches of the same model that lock me out of telnet-ing into them, usually, it's after i go into them and change a simple setting. If I disconnect and reconnect to them, from then on, I get a screen and the password prompts and 3 bad password...

[code:1]
User Access Verification

Password:
Password:
Password:
% Bad passwords


Connection to host lost.

C:\Documents and Settings\jthomas>
[/code:1]

Just a note, I'm not touching a single key when it does this...

Once again, bouncing the power fixes the problem...?

Is this the best workaround?
The administrator has disabled public write access.

Re: 2924/2924C Vlan keeps dropping off? 10 years 8 months ago #12862

  • jwj
  • jwj's Avatar
  • Offline
  • Senior Member
  • Posts: 350
  • Karma: 0
It's probably a buggy version of IOS software that your switches are running. Do all the switches run the same IOS versions? Do you have a Cisco web account to look up known bugs in specific versions? If not, I can look it up for you if need be.
-Jeremy-
The administrator has disabled public write access.

Re: 2924/2924C Vlan keeps dropping off? 10 years 8 months ago #12866

  • illness
  • illness's Avatar
  • Offline
  • Frequent Member
  • Posts: 28
  • Karma: 0
I'm new to cisco stuff, as you can probably see.

I don't have and account of any kind with cisco for support.

I have about 15 switches in all, some are 2924's and some are some are 2924C's, 2 of them are 2912MF's.

If I wanted to upgrade the IOS on the switches how would i get the new IOS?

Do I have to buy it from cisco, to upgrade my switches?
The administrator has disabled public write access.

Re: 2924/2924C Vlan keeps dropping off? 10 years 7 months ago #12920

  • jwj
  • jwj's Avatar
  • Offline
  • Senior Member
  • Posts: 350
  • Karma: 0
Your above problems might be because your IOS version is a Maintenance Interim release, Cisco's Bug Tracker tool has no information on bugs for these releases. If you could convince someone to get a stable release version, it'd be the best bet, not to mention your current version may have vulnerabilities. Usually, purchases from Cisco are done through resellers. Cisco.com has a searchable database of resellers. It seems the problems you are getting are just annoying, so perhaps sticking with what you have might be for the best if your company is hesitant in getting a newer release.
-Jeremy-
The administrator has disabled public write access.
Time to create page: 0.085 seconds

CCENT/CCNA

Cisco Routers

  • SSL WebVPN
  • Securing Routers
  • Policy Based Routing
  • Router on-a-Stick

VPN Security

  • Understand DMVPN
  • GRE/IPSec Configuration
  • Site-to-Site IPSec VPN
  • IPSec Modes

Cisco Help

  • VPN Client Windows 8
  • VPN Client Windows 7
  • CCP Display Problem
  • Cisco Support App.

Windows 2012

  • New Features
  • Licensing
  • Hyper-V / VDI
  • Install Hyper-V

Linux

  • File Permissions
  • Webmin
  • Groups - Users
  • Samba Setup